summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2022-11-29 09:53:45 -0600
committerBen Kohler <bkohler@gentoo.org>2022-11-29 09:57:13 -0600
commitc38623241f52f154c55970f62b4c77f85c117277 (patch)
treed1d10ee2e6207606fa7fbdd82ec8320f3898af2a
parentsys-kernel/gentoo-sources: stabilize 5.15.80 for amd64 (diff)
downloadgentoo-c38623241f52f154c55970f62b4c77f85c117277.tar.gz
gentoo-c38623241f52f154c55970f62b4c77f85c117277.tar.bz2
gentoo-c38623241f52f154c55970f62b4c77f85c117277.zip
net-misc/remmina: fix build against gtk+[-wayland]
Closes: https://bugs.gentoo.org/883551 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
-rw-r--r--net-misc/remmina/files/remmina-1.4.27_p20221128-missing-gdk-include.patch13
-rw-r--r--net-misc/remmina/remmina-1.4.27_p20221128.ebuild6
2 files changed, 17 insertions, 2 deletions
diff --git a/net-misc/remmina/files/remmina-1.4.27_p20221128-missing-gdk-include.patch b/net-misc/remmina/files/remmina-1.4.27_p20221128-missing-gdk-include.patch
new file mode 100644
index 000000000000..618dd721a293
--- /dev/null
+++ b/net-misc/remmina/files/remmina-1.4.27_p20221128-missing-gdk-include.patch
@@ -0,0 +1,13 @@
+diff --git a/src/remmina.c b/src/remmina.c
+index 5b59339f8..43834b9bd 100644
+--- a/src/remmina.c
++++ b/src/remmina.c
+@@ -32,6 +32,8 @@
+ *
+ */
+
++#include <gdk/gdk.h>
++
+ #define G_LOG_USE_STRUCTURED
+ #ifndef G_LOG_DOMAIN
+ #define G_LOG_DOMAIN ((gchar*)"remmina")
diff --git a/net-misc/remmina/remmina-1.4.27_p20221128.ebuild b/net-misc/remmina/remmina-1.4.27_p20221128.ebuild
index e643ec1c2dbc..c6a6755dc703 100644
--- a/net-misc/remmina/remmina-1.4.27_p20221128.ebuild
+++ b/net-misc/remmina/remmina-1.4.27_p20221128.ebuild
@@ -16,7 +16,7 @@ SRC_URI="https://gitlab.com/Remmina/Remmina/-/archive/${COMMIT}/Remmina-${COMMIT
LICENSE="GPL-2+-with-openssl-exception"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
-IUSE="+appindicator crypt cups examples gnome-keyring gvnc kwallet nls python spice ssh rdp telemetry vnc webkit x2go zeroconf"
+IUSE="+appindicator crypt cups examples gnome-keyring gvnc kwallet nls python spice ssh rdp telemetry vnc wayland webkit x2go zeroconf"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
@@ -27,7 +27,7 @@ COMMON_DEPEND="
dev-libs/libsodium:=
dev-libs/openssl:0=
x11-libs/gdk-pixbuf
- x11-libs/gtk+:3
+ x11-libs/gtk+:3[wayland?]
x11-libs/libX11
x11-libs/libxkbfile
appindicator? ( dev-libs/libappindicator:3 )
@@ -67,6 +67,8 @@ DOCS=( AUTHORS CHANGELOG.md README.md THANKS.md )
S="${WORKDIR}/Remmina-${COMMIT}"
+PATCHES=( "${FILESDIR}/${P}-missing-gdk-include.patch" )
+
pkg_setup() {
use python && python-single-r1_pkg_setup
}