summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-06 05:35:42 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-06 06:14:33 +0200
commitc3986dc3cdb527a99a247e6ddac71b78f8bf2be6 (patch)
tree36bb3ac108587cdebacadcffc43bc0667983b9db
parentdev-python/botocore: Bump to 1.29.129 (diff)
downloadgentoo-c3986dc3cdb527a99a247e6ddac71b78f8bf2be6.tar.gz
gentoo-c3986dc3cdb527a99a247e6ddac71b78f8bf2be6.tar.bz2
gentoo-c3986dc3cdb527a99a247e6ddac71b78f8bf2be6.zip
dev-python/boto3: Bump to 1.26.129
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.26.129.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 10771e6a37c7..a973691b4b54 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -1,3 +1,4 @@
DIST boto3-1.26.123.gh.tar.gz 640741 BLAKE2B a4d46a9995ce2c496a1cc0a4f9835474546a2a3b2252793cb80ad08e879afc3b69cc3bd6d6661d52c9812e9bec3f7dc66e5bfeae7761cd1a2f122762abf1f247 SHA512 2640c057a7beda8bafb5aa59af387d368bbf04f9e7a8bbe2ca5fd3adb82eb0480ba3e0b2580331a057ede010a6945397cf056fac210aced4a7c981dfa96c4e85
DIST boto3-1.26.126.gh.tar.gz 642281 BLAKE2B c7a9130cac15843decf4543d6f74904080587d28c1158f6a01e390129a9e4feb8efd2ed806fb428c61e6f84285f4bc1beccb57b1c7fbec56499befeed4663fc9 SHA512 bd9633a2163cc251e83ab6f86d488e436255c6a0240468f372663aab77d09cb6c3039d424c0fda1c1a7c730be8b5cf7011c6e5a7efd04ba9e8e3cd6eb0d49f15
DIST boto3-1.26.127.gh.tar.gz 645245 BLAKE2B fb320e064eae4a6755770653f5519e17ea11aa6f7aa566e0a625b1113cc784440c4d519bb2de544340d66c3fe80a510a1dadba3f724395c186ad7ef68b5ce11f SHA512 df6f9082a159e7ae8033ba92652cde9d73fc8b93e6793d3ce021b75135f825f7e4e102467caa179b36959a42b98376e30ada35d4a3259e359fbf417c92a6e487
+DIST boto3-1.26.129.gh.tar.gz 645918 BLAKE2B 2de3833e60f8a8b91a35c863fc67e1b098b4d51e296a20677ab0e35b62809118dd105cf9338ccef60eef454cbf4b443bf06aa56206a1db4720305bc23ef19d42 SHA512 6b97bee6947eb05e972877b8326b83c4fe6fd244c0ef63da3f2aec801a00810083bb5d4998ec262394cd130393c85f4a0f0cc22f58def1a425def2b3780a48bc
diff --git a/dev-python/boto3/boto3-1.26.129.ebuild b/dev-python/boto3/boto3-1.26.129.ebuild
new file mode 100644
index 000000000000..2a4a7643203e
--- /dev/null
+++ b/dev-python/boto3/boto3-1.26.129.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}