summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-05-12 19:47:32 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-05-13 21:54:21 +0200
commitc39dace4dc0b02095b51e1c3ea809bc40c290125 (patch)
treead360b45acf250501b044b9db5532a67312e0cc4
parentdev-libs/kopeninghours: 22.04.1 version bump (diff)
downloadgentoo-c39dace4dc0b02095b51e1c3ea809bc40c290125.tar.gz
gentoo-c39dace4dc0b02095b51e1c3ea809bc40c290125.tar.bz2
gentoo-c39dace4dc0b02095b51e1c3ea809bc40c290125.zip
dev-libs/kosmindoormap: 22.04.1 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-libs/kosmindoormap/Manifest1
-rw-r--r--dev-libs/kosmindoormap/kosmindoormap-22.04.1.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-libs/kosmindoormap/Manifest b/dev-libs/kosmindoormap/Manifest
index 3d12b1d57b8b..16ddf92f7c69 100644
--- a/dev-libs/kosmindoormap/Manifest
+++ b/dev-libs/kosmindoormap/Manifest
@@ -1,2 +1,3 @@
DIST kosmindoormap-21.12.3.tar.xz 351272 BLAKE2B 8fde9196e18062770c63eb2b636bf3bfea65d8575f4d67106c28fcf3349c6d9bfa3bd1d48a8978b3ec2e2d027f89be3338b88cdfd4b59b7609cc9bba2aeab689 SHA512 f2f5bc04dbb9943114d9807787d98ad4a4963be556c5f2ec332c59bc60533abbf6d39b982f79264ff3d764cb4b8e60501d711039e0fc475500abbd800fc13b86
DIST kosmindoormap-22.04.0.tar.xz 351100 BLAKE2B bfc1401ff87fe10c0bee0b395dbb1386ed424521d72622450038851b768e429323966a8417a0605a456ca19bee58ba1a555e94e54e7bf40abbf9eb863ba3bab1 SHA512 477c1674ebf11a664e7286723a616c6146cfa54827c1eee8aa68e907bd3be068dd8fc90829895fdecff6827bdd3e930728100393071e5dcd6107d0317d318e58
+DIST kosmindoormap-22.04.1.tar.xz 351200 BLAKE2B c3e516c3e840d100cf783f863e105926d5cdad1d44b0010e716014f39469862f7b90b97a88bbd9be91aa63342331bf919b9b0c6508d7037c61817133af6436dc SHA512 efef924a9882ed69b35ee8215eddd0121af55dae10ac18c2294abcee3d9a22c368ff94383b2af62060a090bd6176b27778ea20b229e2f8623179abe3ac606bbc
diff --git a/dev-libs/kosmindoormap/kosmindoormap-22.04.1.ebuild b/dev-libs/kosmindoormap/kosmindoormap-22.04.1.ebuild
new file mode 100644
index 000000000000..db79b01a49e9
--- /dev/null
+++ b/dev-libs/kosmindoormap/kosmindoormap-22.04.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="true"
+KDE_GEAR="true"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.92.0
+QTMIN=5.15.3
+inherit ecm kde.org
+
+DESCRIPTION="Data Model and Extraction System for Travel Reservation information"
+HOMEPAGE="https://invent.kde.org/libraries/kosmindoormap"
+
+LICENSE="LGPL-2+"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE="+openinghours"
+
+COMMON_DEPEND="
+ >=dev-libs/kpublictransport-${PVCUT}:5
+ dev-libs/protobuf:=
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ sys-libs/zlib
+ openinghours? ( >=dev-libs/kopeninghours-${PVCUT}:5 )
+"
+DEPEND="${COMMON_DEPEND}
+ test? ( >=dev-qt/qtwidgets-${QTMIN}:5 )
+"
+RDEPEND="${COMMON_DEPEND}
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_OsmTools=ON # we have no use for it
+ $(cmake_use_find_package openinghours KOpeningHours)
+ )
+ ecm_src_configure
+}