summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-19 23:58:23 +0000
committerSam James <sam@gentoo.org>2023-03-19 23:58:40 +0000
commitc39f2ef845ba68c705303475f1f39d041600db76 (patch)
treedfd1801c6094b3128ff399b1d2c749819eec2164
parentdev-vcs/stgit: fix LDFLAGS QA warning (diff)
downloadgentoo-c39f2ef845ba68c705303475f1f39d041600db76.tar.gz
gentoo-c39f2ef845ba68c705303475f1f39d041600db76.tar.bz2
gentoo-c39f2ef845ba68c705303475f1f39d041600db76.zip
sys-apps/grep: add 3.9_p20230319 (unkeyworded)
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-apps/grep/Manifest2
-rw-r--r--sys-apps/grep/grep-3.9_p20230319.ebuild115
2 files changed, 117 insertions, 0 deletions
diff --git a/sys-apps/grep/Manifest b/sys-apps/grep/Manifest
index bdbbc6f7590c..a7a44e273c53 100644
--- a/sys-apps/grep/Manifest
+++ b/sys-apps/grep/Manifest
@@ -4,5 +4,7 @@ DIST grep-3.8.tar.xz 1709536 BLAKE2B 24cf6f7aa35c85f59f508969ee9731c5be1e5c613e6
DIST grep-3.8.tar.xz.sig 833 BLAKE2B 40f472389705375611015ba0eb85eb32643304b1a324877a75821d086a128a20d00df3d7cd960ec45709f40f21488bbcf993c6fe667ef23663688b33296e650b SHA512 8266b58485f225c2189814e3898c72e59d251b729e0c302d31f57abdb7ac2e6e28dde2c5c8095673b6f007b2a3ebc26db1dca910a7771aba80dad4b3c6761ee4
DIST grep-3.9.4-c83f.tar.xz 1684888 BLAKE2B b50d526c2552bc59807cc4ea2ed8ccbac3a93726c4b1c6e5cb6bd51a875aa0fc20d5642cc449593a3223c8838bd24f21efdf495509cacfec6dfc7092b2bcd169 SHA512 1c7062ec1c39904e84a092b512ddcb2fd97320cf9dff9f6dcd01f3cd5edcf52a4752cc68de26fc7f5016b0d08b40333916f1ba607a5c54a1b175e780bb9c7892
DIST grep-3.9.4-c83f.tar.xz.sig 833 BLAKE2B d785c4dd27c735d89471979971d59428ccf2cd2141001e3a7b9edf18d4ccd3d6af7ffbf0f251ba042737222f0dd0b590a867d8142802ce30b1e7d6cab6b2fbe1 SHA512 c09e1835bd0f117249152637d408e816652a49373edb4822a1f95c33786a859d88e9a4be76671a35f74e9d9673a4741e5757f087aa82b4002c8bcf578a085137
+DIST grep-3.9.8-026c.tar.xz 1685328 BLAKE2B 1505fabf4614ba270cc7bc2c71152aa611050f0431687894e187ec93d069ed6d9b8a888406ea7461216fb9d8d42fa5ad293161c2535121875a8b21eb64b5fc9e SHA512 b11ff829590a875b7d53bb3f7e8c46f01b5dc89133eacb4a55941a1906ca1d2b99eeaef1fd0d07b9b265b972bc782ac311b5e5f0e43f8ef51c5c944b1e22317b
+DIST grep-3.9.8-026c.tar.xz.sig 833 BLAKE2B 84c2aff801eaf075be6fcf985ffb4ea144c2c07d43b9df71e123b9b87b504ab3065e84ae1ee4a18c902215afbef4ecdc772bbede857cce74188099f6222be60e SHA512 6274b204156eb91dbcc65e279f808e8f865220ff10550c468d44823e65ae0e1d7da51d8468315fff326bfc4f13f9edbdc873799ed4cfbce388bd1a76781e675b
DIST grep-3.9.tar.xz 1680380 BLAKE2B 33fefce2a831ad6f00f2eb1d8a063cf280635f2d9c481c98981f7a2ff143c846ab570a448c9c02c3ba08cf2c98612cb364d2d033baf92d62c4515315453cc6f9 SHA512 38aaa28bded9f6d1d527356e9e63bb1dafb4ec8f09e83f2d3bc86c1d6af1a5a8cb9895067375b5b8929ec2cba6ab71c369ed4c6e2a0f7a01dec3c11a6f4c1836
DIST grep-3.9.tar.xz.sig 833 BLAKE2B bbb8a07986368755276c6648378afdbec44da2873574ebb0dce634b0e90da2cb6fd0eaf64969843e2fe65ae5e83aba6b1fea9fde9b246fbedf982393cf54b715 SHA512 d50e11d0d333c09a6afcae511c93cfb54d9dd0a6600f271abf5e103cbf8bdcf9b8606924d7c71770e20c35df5d5468dc339cea1f05d257776734e17f8378d891
diff --git a/sys-apps/grep/grep-3.9_p20230319.ebuild b/sys-apps/grep/grep-3.9_p20230319.ebuild
new file mode 100644
index 000000000000..9b91be42e509
--- /dev/null
+++ b/sys-apps/grep/grep-3.9_p20230319.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/grep.asc
+inherit flag-o-matic verify-sig
+
+DESCRIPTION="GNU regular expression matcher"
+HOMEPAGE="https://www.gnu.org/software/grep/"
+
+if [[ ${PV} == *_p* ]] ; then
+ # Subscribe to the 'platform-testers' ML to find these.
+ # Useful to test on our especially more niche arches and report issues upstream.
+ MY_COMMIT="8-026c"
+ MY_P=${PN}-$(ver_cut 1-2).${MY_COMMIT}
+ SRC_URI="https://meyering.net/${PN}/${MY_P}.tar.xz"
+ SRC_URI+=" verify-sig? ( https://meyering.net/${PN}/${MY_P}.tar.xz.sig )"
+ S="${WORKDIR}"/${MY_P}
+else
+ SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+ SRC_URI+=" verify-sig? ( mirror://gnu/${PN}/${P}.tar.xz.sig )"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="+egrep-fgrep nls pcre static"
+
+# We lack dev-libs/libsigsegv[static-libs] for now
+REQUIRED_USE="static? ( !sparc )"
+
+LIB_DEPEND="
+ pcre? ( >=dev-libs/libpcre2-7.8-r1[static-libs(+)] )
+ sparc? ( dev-libs/libsigsegv )
+"
+RDEPEND="
+ !static? ( ${LIB_DEPEND//\[static-libs(+)]} )
+ nls? ( virtual/libintl )
+ virtual/libiconv
+"
+DEPEND="
+ ${RDEPEND}
+ static? ( ${LIB_DEPEND} )
+"
+BDEPEND="
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+ verify-sig? ( sec-keys/openpgp-keys-grep )
+"
+
+DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
+
+QA_CONFIG_IMPL_DECL_SKIP=(
+ # Either gnulib FPs or fixed in newer autoconf, not worth autoreconf here for now?
+ MIN
+ alignof
+ static_assert
+)
+
+src_prepare() {
+ default
+
+ # bug #523898
+ sed -i \
+ -e "s:@SHELL@:${EPREFIX}/bin/sh:g" \
+ -e "s:@grep@:${EPREFIX}/bin/grep:" \
+ src/egrep.sh || die
+}
+
+src_configure() {
+ use static && append-ldflags -static
+
+ # We used to turn this off unconditionally (bug #673524) but we now
+ # allow it for cases where libsigsegv is better for userspace handling
+ # of stack overflows.
+ # In particular, it's necessary for sparc: bug #768135
+ export ac_cv_libsigsegv=$(usex sparc)
+
+ local myeconfargs=(
+ --bindir="${EPREFIX}"/bin
+ $(use_enable nls)
+ $(use_enable pcre perl-regexp)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ if use egrep-fgrep ; then
+ # Delete the upstream wrapper variants which warn on egrep+fgrep use
+ rm "${ED}"/bin/{egrep,fgrep} || die
+
+ into /
+ # Install egrep, fgrep which don't warn.
+ #
+ # We do this by default to avoid breakage in old scripts
+ # and such which don't expect unexpected output on stderr,
+ # we've had examples of builds failing because foo-config
+ # starts returning a warning.
+ #
+ # https://lists.gnu.org/archive/html/bug-grep/2022-10/msg00000.html
+ newbin - egrep <<-EOF
+ #!/usr/bin/env sh
+ exec "${EPREFIX}/bin/grep" -E "\$@"
+ EOF
+
+ newbin - fgrep <<-EOF
+ #!/usr/bin/env sh
+ exec "${EPREFIX}/bin/grep" -F "\$@"
+ EOF
+ fi
+}