summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2022-09-17 09:48:34 +0300
committerJoonas Niilola <juippis@gentoo.org>2022-09-17 09:50:04 +0300
commitc3b8050e2049e643f1a5b7c03cabf2dca104261d (patch)
tree04f4ec5cb73058921bb4b0a665248cf0cf5e9e46
parentdev-lang/spidermonkey: fix compiling 91.13.0 with rust-1.63 (diff)
downloadgentoo-c3b8050e2049e643f1a5b7c03cabf2dca104261d.tar.gz
gentoo-c3b8050e2049e643f1a5b7c03cabf2dca104261d.tar.bz2
gentoo-c3b8050e2049e643f1a5b7c03cabf2dca104261d.zip
dev-lang/spidermonkey: fix compiling 102.2.0 with rust-1.63
- by disabling rust-simd, just a temporary fix for now, 102.3.0 release will fix it properly. Bug: https://bugs.gentoo.org/870193 Closes: https://github.com/gentoo/gentoo/pull/27085 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--dev-lang/spidermonkey/spidermonkey-102.2.0.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/dev-lang/spidermonkey/spidermonkey-102.2.0.ebuild b/dev-lang/spidermonkey/spidermonkey-102.2.0.ebuild
index 36b001f06eb5..d04917ec1b05 100644
--- a/dev-lang/spidermonkey/spidermonkey-102.2.0.ebuild
+++ b/dev-lang/spidermonkey/spidermonkey-102.2.0.ebuild
@@ -290,9 +290,11 @@ src_configure() {
$(use_enable test tests)
)
- if ! use x86 && [[ ${CHOST} != armv*h* ]] ; then
- myeconfargs+=( --enable-rust-simd )
- fi
+ # Temporary fix against rust-1.63, bgo#870193
+ # if ! use x86 && [[ ${CHOST} != armv*h* ]] ; then
+ # myeconfargs+=( --enable-rust-simd )
+ #fi
+ myeconfargs+=( --disable-rust-simd )
# Modifications to better support ARM, bug 717344
if use cpu_flags_arm_neon ; then