summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-03-20 21:21:38 +0100
committerPacho Ramos <pacho@gentoo.org>2023-03-20 21:21:38 +0100
commitc3e4562f4be5db8b8fd49161c8a36fea45c9ecca (patch)
treed7710fc3b78ec1ca8e3a0ccb0b5513f45d3038dc
parentdev-util/scons: Backport MergeFlags fix to 4.5.1 (diff)
downloadgentoo-c3e4562f4be5db8b8fd49161c8a36fea45c9ecca.tar.gz
gentoo-c3e4562f4be5db8b8fd49161c8a36fea45c9ecca.tar.bz2
gentoo-c3e4562f4be5db8b8fd49161c8a36fea45c9ecca.zip
sci-chemistry/chemical-mime-data: add 0.1.95_pre20171122
Closes: https://bugs.gentoo.org/578628 Closes: https://bugs.gentoo.org/710906 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--sci-chemistry/chemical-mime-data/Manifest1
-rw-r--r--sci-chemistry/chemical-mime-data/chemical-mime-data-0.1.95_pre20171122.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/sci-chemistry/chemical-mime-data/Manifest b/sci-chemistry/chemical-mime-data/Manifest
index c029ce5a966c..c87c4dfa11bc 100644
--- a/sci-chemistry/chemical-mime-data/Manifest
+++ b/sci-chemistry/chemical-mime-data/Manifest
@@ -1 +1,2 @@
DIST chemical-mime-data-0.1.94.tar.bz2 146077 BLAKE2B 9996c240446dc9571b6b4afbcdc6cf16a08e11314da9f785490b1b20933b6d18a333132492e30315c08f4441c048ec593a111815253050cfb5ab562aadb784f1 SHA512 7f3d967149f27ab1de53c948dc055959e661e1be9d778e3d56d06bea95769da7770ab5fb66afab6607747ef91ffb1dbbcf921e5f06e3303351781968594b5f00
+DIST chemical-mime-data-0.1.95_pre20171122.tar.gz 84515 BLAKE2B 42f76b44408c04e5a254c17502ea2c297727bb58fa3e86b8bca7f0c4c056ae7400b31f06b7d0c64b0712e97ab8a1f82549f44a3677720cd37a301ba99adb3d7a SHA512 a031e7a5bc31a74adcd8e5d827de71b6e0eafdceba16cf6f7407aa0266a9a082b0011963b315d2369f39abf45c4b41cedafccddbc2171673bf96ccbea51a4790
diff --git a/sci-chemistry/chemical-mime-data/chemical-mime-data-0.1.95_pre20171122.ebuild b/sci-chemistry/chemical-mime-data/chemical-mime-data-0.1.95_pre20171122.ebuild
new file mode 100644
index 000000000000..13b91f044ac8
--- /dev/null
+++ b/sci-chemistry/chemical-mime-data/chemical-mime-data-0.1.95_pre20171122.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit autotools xdg
+
+DESCRIPTION="A collection of data files to add support for chemical MIME types"
+HOMEPAGE="https://github.com/dleidert/chemical-mime"
+COMMIT="4fd66e3b3b7d922555d1e25587908b036805c45b"
+SRC_URI="https://github.com/dleidert/chemical-mime/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="x11-misc/shared-mime-info"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/intltool
+ dev-util/desktop-file-utils
+ dev-libs/libxslt
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # https://github.com/dleidert/chemical-mime/issues/5
+ "${FILESDIR}"/${PN}-0.1.95-turbomole.patch
+)
+
+S="${WORKDIR}/${PN/-data/}-${COMMIT}"
+
+src_prepare() {
+ default
+ # https://github.com/dleidert/chemical-mime/issues/4
+ sed -i -e \
+ '/<_comment/a\\t\t<generic-icon name="image-x-generic"/>' \
+ src/chemical-mime-database.xml.in || die
+ sed -i -e \
+ 's:acronym|alias|comment|:acronym|alias|comment|generic-icon|:' \
+ xsl/cmd_freedesktop_org.xsl || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-update-database \
+ --without-gnome-mime \
+ --without-kde-mime \
+ --without-kde-magic
+}