summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-13 19:49:11 +0100
committerSam James <sam@gentoo.org>2022-09-13 19:49:11 +0100
commitc426c431c1c4a0bd0991da78dad1f707bc23adb2 (patch)
treed5770e6ca7f38909621b19c751cd4dbd5aa03fbd
parentdev-libs/boehm-gc: fix configure tests with Clang 15 (diff)
downloadgentoo-c426c431c1c4a0bd0991da78dad1f707bc23adb2.tar.gz
gentoo-c426c431c1c4a0bd0991da78dad1f707bc23adb2.tar.bz2
gentoo-c426c431c1c4a0bd0991da78dad1f707bc23adb2.zip
sys-libs/llvm-libunwind: filter LTO
1. Upstream bug (https://github.com/llvm/llvm-project/issues/56825) where there may be serious runtime issues; 2. ODR warnings. Closes: https://bugs.gentoo.org/863917 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-13.0.1-r1.ebuild (renamed from sys-libs/llvm-libunwind/llvm-libunwind-13.0.1.ebuild)6
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-14.0.6-r1.ebuild (renamed from sys-libs/llvm-libunwind/llvm-libunwind-14.0.6.ebuild)6
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-15.0.0-r1.ebuild (renamed from sys-libs/llvm-libunwind/llvm-libunwind-15.0.0.ebuild)4
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-15.0.0.9999.ebuild4
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-16.0.0.9999.ebuild4
5 files changed, 22 insertions, 2 deletions
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-13.0.1.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-13.0.1-r1.ebuild
index 282953294291..1de0765ec1bf 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-13.0.1.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-13.0.1-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python3_{8..10} )
-inherit cmake-multilib llvm llvm.org python-any-r1 toolchain-funcs
+inherit cmake-multilib flag-o-matic llvm llvm.org python-any-r1 toolchain-funcs
DESCRIPTION="C++ runtime stack unwinder from LLVM"
HOMEPAGE="https://llvm.org/docs/ExceptionHandling.html"
@@ -41,6 +41,10 @@ multilib_src_configure() {
local use_compiler_rt=OFF
local libdir=$(get_libdir)
+ # https://github.com/llvm/llvm-project/issues/56825
+ # also separately bug #863917
+ filter-lto
+
# link to compiler-rt
# https://github.com/gentoo/gentoo/pull/21516
if tc-is-clang; then
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-14.0.6.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-14.0.6-r1.ebuild
index ac1952b256cf..3596ed724fe0 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-14.0.6.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-14.0.6-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
-inherit cmake-multilib llvm llvm.org python-any-r1 toolchain-funcs
+inherit cmake-multilib flag-o-matic llvm llvm.org python-any-r1 toolchain-funcs
DESCRIPTION="C++ runtime stack unwinder from LLVM"
HOMEPAGE="https://llvm.org/docs/ExceptionHandling.html"
@@ -45,6 +45,10 @@ multilib_src_configure() {
local use_compiler_rt=OFF
local libdir=$(get_libdir)
+ # https://github.com/llvm/llvm-project/issues/56825
+ # also separately bug #863917
+ filter-lto
+
# link to compiler-rt
# https://github.com/gentoo/gentoo/pull/21516
if tc-is-clang; then
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-15.0.0.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-15.0.0-r1.ebuild
index a82604936035..266fb98a49d9 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-15.0.0.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-15.0.0-r1.ebuild
@@ -49,6 +49,10 @@ multilib_src_configure() {
local use_compiler_rt=OFF
local libdir=$(get_libdir)
+ # https://github.com/llvm/llvm-project/issues/56825
+ # also separately bug #863917
+ filter-lto
+
if use clang && ! tc-is-clang; then
# Only do this conditionally to allow overriding with
# e.g. CC=clang-13 in case of breakage
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-15.0.0.9999.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-15.0.0.9999.ebuild
index 2decc6f4c6ee..c682d12707f2 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-15.0.0.9999.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-15.0.0.9999.ebuild
@@ -49,6 +49,10 @@ multilib_src_configure() {
local use_compiler_rt=OFF
local libdir=$(get_libdir)
+ # https://github.com/llvm/llvm-project/issues/56825
+ # also separately bug #863917
+ filter-lto
+
if use clang && ! tc-is-clang; then
# Only do this conditionally to allow overriding with
# e.g. CC=clang-13 in case of breakage
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-16.0.0.9999.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-16.0.0.9999.ebuild
index 2decc6f4c6ee..c682d12707f2 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-16.0.0.9999.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-16.0.0.9999.ebuild
@@ -49,6 +49,10 @@ multilib_src_configure() {
local use_compiler_rt=OFF
local libdir=$(get_libdir)
+ # https://github.com/llvm/llvm-project/issues/56825
+ # also separately bug #863917
+ filter-lto
+
if use clang && ! tc-is-clang; then
# Only do this conditionally to allow overriding with
# e.g. CC=clang-13 in case of breakage