summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-09-21 01:10:17 -0400
committerTim Harder <radhermit@gentoo.org>2017-09-21 01:14:53 -0400
commitc42a32b51d5c84941f14f3341a55973196d430dc (patch)
treee4d472bbb6ef9adfbc222bdd581424ca36675705
parentdev-python/setuptools: version bump to 36.5.0 (diff)
downloadgentoo-c42a32b5.tar.gz
gentoo-c42a32b5.tar.bz2
gentoo-c42a32b5.zip
dev-python/six: version bump to 1.11.0
-rw-r--r--dev-python/six/Manifest1
-rw-r--r--dev-python/six/files/1.9.0-mapping.patch4
-rw-r--r--dev-python/six/six-1.11.0.ebuild39
3 files changed, 42 insertions, 2 deletions
diff --git a/dev-python/six/Manifest b/dev-python/six/Manifest
index 810f4cc53156..752234cb8fde 100644
--- a/dev-python/six/Manifest
+++ b/dev-python/six/Manifest
@@ -1 +1,2 @@
DIST six-1.10.0.tar.gz 29630 SHA256 105f8d68616f8248e24bf0e9372ef04d3cc10104f1980f54d57b2ce73a5ad56a SHA512 9a53b7bc8f7e8b358c930eaecf91cc5639176a699830153f586780c3e6d637f1bd31349a69c383574f99da19cb3a36524e7733a318f3572b27aefb69c6409c2e WHIRLPOOL aad2fc7438b0df029bf477a783161dc169795c355be1281f1fe7aa4eb959eae5abf3bc96d097a221e0e5ad0b0494c29025bbe99bc28ff0c29ae1776e8691a70a
+DIST six-1.11.0.tar.gz 29860 SHA256 70e8a77beed4562e7f14fe23a786b54f6296e34344c23bc42f07b15018ff98e9 SHA512 33f246a2e987141e17e5edad9d3537cf3aba0cbdd0bc2a907ea52ce0d674b1474f29c3dd5cc26605fd960396054b189ca5f501708333cad234c223131483fe24 WHIRLPOOL 08e33e1742d69558faa67fad1807b567595aa4c838bb643c993bcb88661246a0f14974ff89d1f9d25842212bfaeac0cb3a69272deacb8872b9ca3fb2f55570b9
diff --git a/dev-python/six/files/1.9.0-mapping.patch b/dev-python/six/files/1.9.0-mapping.patch
index 96ca9b649c5b..4423eacbbba3 100644
--- a/dev-python/six/files/1.9.0-mapping.patch
+++ b/dev-python/six/files/1.9.0-mapping.patch
@@ -1,7 +1,7 @@
Patch prevents downloading non essential .inv files during the doc build
diff -ur six-1.5.2.orig/documentation/conf.py six-1.5.2/documentation/conf.py
---- documentation/conf.py 2013-09-15 21:52:34.000000000 +0800
-+++ documentation/conf.py 2014-01-07 18:19:24.958916446 +0800
+--- a/documentation/conf.py 2013-09-15 21:52:34.000000000 +0800
++++ b/documentation/conf.py 2014-01-07 18:19:24.958916446 +0800
@@ -211,7 +211,3 @@
[u"Benjamin Peterson"], 1)
]
diff --git a/dev-python/six/six-1.11.0.ebuild b/dev-python/six/six-1.11.0.ebuild
new file mode 100644
index 000000000000..5934f751afa2
--- /dev/null
+++ b/dev-python/six/six-1.11.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python 2 and 3 compatibility library"
+HOMEPAGE="https://bitbucket.org/gutworth/six https://pypi.python.org/pypi/six"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx )
+ test? ( >=dev-python/pytest-2.2.0[${PYTHON_USEDEP}] )"
+
+PATCHES=(
+ "${FILESDIR}"/1.9.0-mapping.patch
+)
+
+python_compile_all() {
+ use doc && emake -C documentation html
+}
+
+python_test() {
+ py.test -v || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( documentation/_build/html/. )
+ distutils-r1_python_install_all
+}