summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-03 10:02:06 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-03 12:35:08 +0200
commitc42fd80102d8ecfd7549738080e4ce400ad62b09 (patch)
tree436120fda47ba502cfc6914dd3d204a3c2fd307d
parentdev-python/nest_asyncio: Bump to 1.5.5 (diff)
downloadgentoo-c42fd801.tar.gz
gentoo-c42fd801.tar.bz2
gentoo-c42fd801.zip
dev-python/moto: Bump to 3.1.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/moto/Manifest1
-rw-r--r--dev-python/moto/moto-3.1.4.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/dev-python/moto/Manifest b/dev-python/moto/Manifest
index 64b8bf5cdd38..b6ebdb194941 100644
--- a/dev-python/moto/Manifest
+++ b/dev-python/moto/Manifest
@@ -2,3 +2,4 @@ DIST moto-3.0.5.tar.gz 2219507 BLAKE2B 019e0f66d8a183f9d758c372252488e79692e140d
DIST moto-3.1.1.tar.gz 2236948 BLAKE2B 8ab52a59dc09f4819c1169d26fd198b13159635c2571fd27e38eaedc0a83fa5e7af0a7adba90db1c48658a849ff0b17e8d9c9750a47c6981960ac786f3d9a4e0 SHA512 2354886a9b3b46bb33b832495a94f1dcd10cf5cb00454b6e8b6b6838618842ca06f8577c1826bca02a10e2f723cf474a7c492cd9fb587bdb660deb118c17aa4d
DIST moto-3.1.2.tar.gz 2245068 BLAKE2B f25a4476bfbbbd3cab77efc1ef2ceeb74b2b7ee9067aac4a02f90c6fd385c5ed0d66d3fd8171945e22dcd78555c9fdbec78656109b9f61fd15950c44b456d4ea SHA512 51dfef58069f09b4654aa59bef2ee0426c0e662af51d78013c19671b664ade78d2c664c20f19592236808ba7bcc50613700232e87be1ac8dcead4be2df36d39b
DIST moto-3.1.3.tar.gz 2246198 BLAKE2B 935271da2b09b160c7ed8c8b1e2466b352d879c7b8bbe4406a410c301f9659fde3187ed76f2ad6695c79a667a44c698570dcb30206a0fe0b525a5e5bef72f40c SHA512 20963f9a1a99a2ac1654660284b3cb60439538da0d363baba92e813dd3c7bde815c125bc39cd1cf5c0cd883fba024dfda85b7e98a54141ad3e25311986c68c9a
+DIST moto-3.1.4.tar.gz 2256325 BLAKE2B d0b90eee9f77370ea48e95a5920b139825550850276760842e16ddbe340e09746a0ec6c4e4d9a57f8a68232d807b17920fff4bd88a9a75d0a72c8153cb5cbfb1 SHA512 3ec226dc19b46af50f4a266957e54292b65b9b198a5daf2f5eba6242cf2ab9a42ba743d0af1f30695de625e9fa222871890b497717ac2b9ed111b033f3804b25
diff --git a/dev-python/moto/moto-3.1.4.ebuild b/dev-python/moto/moto-3.1.4.ebuild
new file mode 100644
index 000000000000..49b6647dfd22
--- /dev/null
+++ b/dev-python/moto/moto-3.1.4.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Mock library for boto"
+HOMEPAGE="https://github.com/spulec/moto"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-xray-sdk-python-0.93[${PYTHON_USEDEP}]
+ dev-python/boto[${PYTHON_USEDEP}]
+ dev-python/cfn-lint[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-3.3.1[${PYTHON_USEDEP}]
+ dev-python/cookies[${PYTHON_USEDEP}]
+ >=dev-python/docker-py-2.5.1[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.5[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.10.1[${PYTHON_USEDEP}]
+ >=dev-python/jsondiff-1.1.2[${PYTHON_USEDEP}]
+ dev-python/boto3[${PYTHON_USEDEP}]
+ dev-python/botocore[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/flask-cors[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ dev-python/pretty-yaml[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/python-jose[${PYTHON_USEDEP}]
+ dev-python/python-sshpubkeys[${PYTHON_USEDEP}]
+ >=dev-python/responses-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.5[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/zipp[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ >=dev-python/sure-1.4.11[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/test_firehose/test_firehose_put.py::test_put_record_http_destination
+ tests/test_firehose/test_firehose_put.py::test_put_record_batch_http_destination
+ tests/test_swf/responses/test_decision_tasks.py::test_respond_decision_task_completed_with_schedule_activity_task_boto3
+ tests/test_swf/responses/test_timeouts.py::test_activity_task_heartbeat_timeout_boto3
+ tests/test_swf/responses/test_timeouts.py::test_decision_task_start_to_close_timeout_boto3
+ tests/test_swf/responses/test_timeouts.py::test_workflow_execution_start_to_close_timeout_boto3
+ # broken code (local variable used referenced before definition)
+ tests/test_appsync/test_appsync_schema.py
+ # Needs network (or docker?) but not marked as such, bug #807031
+ # TODO: report upstream
+ tests/test_batch/test_batch_jobs.py::test_terminate_job
+ tests/test_batch/test_batch_jobs.py::test_cancel_pending_job
+ tests/test_batch/test_batch_jobs.py::test_cancel_running_job
+ tests/test_batch/test_batch_jobs.py::test_dependencies
+ tests/test_batch/test_batch_jobs.py::test_container_overrides
+ tests/test_cloudformation/test_cloudformation_custom_resources.py::test_create_custom_lambda_resource__verify_cfnresponse_failed
+ tests/test_cloudformation/test_cloudformation_stack_integration.py::test_lambda_function
+ tests/test_sqs/test_integration.py::test_invoke_function_from_sqs_exception
+ tests/test_sqs/test_sqs_integration.py::test_invoke_function_from_sqs_exception
+ )
+
+ # pytest-django causes freezegun try to mangle stuff inside django
+ # which fails when django is not really used
+ epytest -p no:django -m 'not network'
+}