summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorQuentin Retornaz <gentoo@retornaz.com>2020-09-07 23:25:11 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-09-28 14:16:59 +0300
commitc42fef2a7d24eb6598be35fc0a2e218406532b5b (patch)
tree6bda86e4edae437efb5e054c904e13338cb9945d
parentlxde-base/lxterminal: port to EAPI 7, tidy up ebuild (diff)
downloadgentoo-c42fef2a7d24eb6598be35fc0a2e218406532b5b.tar.gz
gentoo-c42fef2a7d24eb6598be35fc0a2e218406532b5b.tar.bz2
gentoo-c42fef2a7d24eb6598be35fc0a2e218406532b5b.zip
net-analyzer/nikto: new package
- nikto is a web server vulnerability scanner. Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Quentin Retornaz <gentoo@retornaz.com> Closes: https://github.com/gentoo/gentoo/pull/17460 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--net-analyzer/nikto/Manifest1
-rw-r--r--net-analyzer/nikto/metadata.xml12
-rw-r--r--net-analyzer/nikto/nikto-2.1.6_p20200901.ebuild46
3 files changed, 59 insertions, 0 deletions
diff --git a/net-analyzer/nikto/Manifest b/net-analyzer/nikto/Manifest
new file mode 100644
index 000000000000..be93f585da68
--- /dev/null
+++ b/net-analyzer/nikto/Manifest
@@ -0,0 +1 @@
+DIST nikto-2.1.6_p20200901.tar.gz 521285 BLAKE2B 243f0baf5835e5586b8270fc9dd1005c08e903f478666359c34bb0d30c0645f5ab9a19109718dbbd2f6015dcb64c3a98b832b5412c9151720dedd102fb1936d1 SHA512 88b9e681ce4588e3473f90c93ea41d46fc99a54b895185465cfe1a28152ad944edbadfcf5cee4540b4ec48eb78ca73a1952637c3da9038e52d837c0de5d0260c
diff --git a/net-analyzer/nikto/metadata.xml b/net-analyzer/nikto/metadata.xml
new file mode 100644
index 000000000000..91f5940d4d0a
--- /dev/null
+++ b/net-analyzer/nikto/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@retornaz.com</email>
+ <name>Quentin Retornaz</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-analyzer/nikto/nikto-2.1.6_p20200901.ebuild b/net-analyzer/nikto/nikto-2.1.6_p20200901.ebuild
new file mode 100644
index 000000000000..5d64088ea896
--- /dev/null
+++ b/net-analyzer/nikto/nikto-2.1.6_p20200901.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Web server vulnerability scanner"
+HOMEPAGE="https://www.cirt.net/Nikto2"
+COMMIT="fb2655b8316097723d4977c792817a21117b2736"
+MY_P="${PN}-${COMMIT}"
+SRC_URI="https://github.com/sullo/nikto/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+
+# nikto provides its own libwhisker, do no use net-libs/libwhisker[ssl]
+# https://bugs.gentoo.org/533900
+RDEPEND="
+ dev-lang/perl
+ dev-perl/Net-SSLeay
+ net-analyzer/nmap
+ virtual/perl-JSON-PP
+"
+
+S="${WORKDIR}/${MY_P}/program"
+
+src_prepare() {
+ sed -i -e 's:/etc/nikto.conf:/etc/nikto/nikto.conf:' nikto.pl || die
+ sed -i -e 's:# EXECDIR=/opt/nikto:EXECDIR=/usr/share/nikto:' nikto.conf.default || die
+
+ default
+}
+
+src_install() {
+ insinto /etc/nikto
+ newins nikto.conf.default nikto.conf
+
+ dobin nikto.pl replay.pl
+ dosym nikto.pl /usr/bin/nikto
+
+ insinto /usr/share/nikto
+ doins -r plugins templates databases
+
+ dodoc docs/*.txt
+ dodoc docs/nikto_manual.html
+}