summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2018-11-27 20:08:03 +0100
committerTupone Alfredo <tupone@gentoo.org>2018-11-27 20:08:03 +0100
commitc43f4222b7c773c7c1dfcf09fe500b6444cca54d (patch)
tree531071868170b75476615174fe9f0d9db777a98f
parentdev-libs/oniguruma-6.9.0: arm64 stable (bug #671294) (diff)
downloadgentoo-c43f4222.tar.gz
gentoo-c43f4222.tar.bz2
gentoo-c43f4222.zip
dev-ada/gnat_util: Stable
Signed-off-by: Alfredo Tupone <tupone@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--dev-ada/gnat_util/gnat_util-2018.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/dev-ada/gnat_util/gnat_util-2018.ebuild b/dev-ada/gnat_util/gnat_util-2018.ebuild
index a60bab1f3254..c7b5206b2a5d 100644
--- a/dev-ada/gnat_util/gnat_util-2018.ebuild
+++ b/dev-ada/gnat_util/gnat_util-2018.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -14,7 +14,7 @@ SRC_URI="http://mirrors.cdn.adacore.com/art/5b0819dfc7a447df26c27a6b
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
IUSE="gnat_2016 gnat_2017 +gnat_2018 +shared static-libs static-pic"
RDEPEND="dev-lang/gnat-gpl:7.3.1"
@@ -28,16 +28,15 @@ PATCHES=( "${FILESDIR}"/${PN}-2017-gentoo.patch )
src_compile() {
GCC_PV=7.3.1
- GCC=${CHOST}-gcc-${GCC_PV}
GNATMAKE=${CHOST}-gnatmake-${GCC_PV}
emake GNATMAKE="${GNATMAKE} ${ADAFLAGS}" \
BUILDER="gprbuild -j$(makeopts_jobs)" generate_sources
if use static-libs; then
- emake CC="${GCC}" BUILDER="gprbuild -v -j$(makeopts_jobs)" build-static
+ emake BUILDER="gprbuild -v -j$(makeopts_jobs)" build-static
fi
for kind in shared static-pic; do
if use ${kind}; then
- emake CC="${GCC}" BUILDER="gprbuild -v -j$(makeopts_jobs)" \
+ emake BUILDER="gprbuild -v -j$(makeopts_jobs)" \
build-${kind}
fi
done