summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-27 10:12:06 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-27 12:29:02 +0300
commitc4488912f7cc1fe4f5fc39023fd5fd707a089c7f (patch)
treec18bc854251f8ffe1354d3feefcd00fd63395fed
parentdev-python/flufl-i18n: add gitlab upstream metadata (diff)
downloadgentoo-c4488912.tar.gz
gentoo-c4488912.tar.bz2
gentoo-c4488912.zip
dev-python/flufl-i18n: enable py3.10, cleanup
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/flufl-i18n/flufl-i18n-3.2.ebuild16
1 files changed, 6 insertions, 10 deletions
diff --git a/dev-python/flufl-i18n/flufl-i18n-3.2.ebuild b/dev-python/flufl-i18n/flufl-i18n-3.2.ebuild
index bc9300e4f4e5..59ecea882559 100644
--- a/dev-python/flufl-i18n/flufl-i18n-3.2.ebuild
+++ b/dev-python/flufl-i18n/flufl-i18n-3.2.ebuild
@@ -3,31 +3,27 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
MY_P=${P/-/.}
+
DESCRIPTION="A high level API for Python internationalization"
HOMEPAGE="https://gitlab.com/warsaw/flufl.i18n"
SRC_URI="mirror://pypi/${PN::1}/${PN/-/.}/${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-RDEPEND="
- dev-python/atpublic[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/typing-extensions[${PYTHON_USEDEP}]
- ' python3_7)"
-BDEPEND="
- test? ( dev-python/sybil[${PYTHON_USEDEP}] )"
+RDEPEND="dev-python/atpublic[${PYTHON_USEDEP}]"
+BDEPEND="test? ( dev-python/sybil[${PYTHON_USEDEP}] )"
distutils_enable_tests pytest
src_prepare() {
- sed -i -e 's:--cov=flufl::' setup.cfg || die
+ sed -e '/addopts/d' -i setup.cfg || die
distutils-r1_src_prepare
}