summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-09-15 17:23:51 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-09-15 17:24:58 +0200
commitc458d1fc49610955d0ec4d82ecbbdf3fd79df418 (patch)
tree47ab92636c7dd1711bc3b958bcb7611b194e2a29
parentnet-mail/vpopmail: make patches apply with -p1 (diff)
downloadgentoo-c458d1fc.tar.gz
gentoo-c458d1fc.tar.bz2
gentoo-c458d1fc.zip
kde-plasma/plasma-nm: Fix missing headers with Frameworks 5.62
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-plasma/plasma-nm/files/plasma-nm-5.16.5-missing-headers.patch62
-rw-r--r--kde-plasma/plasma-nm/plasma-nm-5.16.5.ebuild2
2 files changed, 64 insertions, 0 deletions
diff --git a/kde-plasma/plasma-nm/files/plasma-nm-5.16.5-missing-headers.patch b/kde-plasma/plasma-nm/files/plasma-nm-5.16.5-missing-headers.patch
new file mode 100644
index 000000000000..676087e89ac6
--- /dev/null
+++ b/kde-plasma/plasma-nm/files/plasma-nm-5.16.5-missing-headers.patch
@@ -0,0 +1,62 @@
+From a7eb3cb599fbb1d66c6980d53550822cbbfd1520 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Wed, 14 Aug 2019 11:25:49 +0200
+Subject: Add missing headers with DISABLE_MODEMMANAGER_SUPPORT=ON
+
+Reviewers: jgrulich
+
+Reviewed By: jgrulich
+
+Subscribers: plasma-devel
+
+Tags: #plasma
+
+Differential Revision: https://phabricator.kde.org/D23148
+---
+ libs/declarative/networkstatus.cpp | 2 ++
+ libs/handler.cpp | 1 +
+ libs/handler.h | 1 +
+ 3 files changed, 4 insertions(+)
+
+diff --git a/libs/declarative/networkstatus.cpp b/libs/declarative/networkstatus.cpp
+index b9db376..e94b7ea 100644
+--- a/libs/declarative/networkstatus.cpp
++++ b/libs/declarative/networkstatus.cpp
+@@ -20,7 +20,9 @@
+
+ #include "networkstatus.h"
+ #include "uiutils.h"
++
+ #include <QDBusConnection>
++#include <QDBusConnectionInterface>
+
+ #include <NetworkManagerQt/ActiveConnection>
+ #include <NetworkManagerQt/Connection>
+diff --git a/libs/handler.cpp b/libs/handler.cpp
+index 40b4b43..0095aa7 100644
+--- a/libs/handler.cpp
++++ b/libs/handler.cpp
+@@ -46,6 +46,7 @@
+ #endif
+
+ #include <QDBusError>
++#include <QDBusMetaType>
+ #include <QDBusPendingReply>
+ #include <QIcon>
+
+diff --git a/libs/handler.h b/libs/handler.h
+index f8b7941..4c72699 100644
+--- a/libs/handler.h
++++ b/libs/handler.h
+@@ -22,6 +22,7 @@
+ #define PLASMA_NM_HANDLER_H
+
+ #include <QDBusInterface>
++#include <QTimer>
+
+ #include <NetworkManagerQt/Connection>
+ #include <NetworkManagerQt/Settings>
+--
+cgit v1.1
+
+
diff --git a/kde-plasma/plasma-nm/plasma-nm-5.16.5.ebuild b/kde-plasma/plasma-nm/plasma-nm-5.16.5.ebuild
index 995f4b6b6b89..0a6f38e56d3c 100644
--- a/kde-plasma/plasma-nm/plasma-nm-5.16.5.ebuild
+++ b/kde-plasma/plasma-nm/plasma-nm-5.16.5.ebuild
@@ -53,6 +53,8 @@ RDEPEND="${DEPEND}
$(add_plasma_dep kde-cli-tools)
"
+PATCHES=( "${FILESDIR}/${P}-missing-headers.patch" )
+
src_configure() {
local mycmakeargs=(
-DDISABLE_MODEMMANAGER_SUPPORT=$(usex !modemmanager)