summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2018-08-06 17:53:58 -0700
committerZac Medico <zmedico@gentoo.org>2018-08-06 18:08:12 -0700
commitc45a277ebc0d4be1e4ac87c9c7f9cc9f0a564efe (patch)
tree17f727629a51d9f9208a4da09a3e4018b6a4ee4a
parentdev-lang/erlang: add create pidfile patch for epmd and openrc (diff)
downloadgentoo-c45a277ebc0d4be1e4ac87c9c7f9cc9f0a564efe.tar.gz
gentoo-c45a277ebc0d4be1e4ac87c9c7f9cc9f0a564efe.tar.bz2
gentoo-c45a277ebc0d4be1e4ac87c9c7f9cc9f0a564efe.zip
app-emulation/buildah: remove old version 1.1
Package-Manager: Portage-2.3.44, Repoman-2.3.10
-rw-r--r--app-emulation/buildah/Manifest1
-rw-r--r--app-emulation/buildah/buildah-1.1.ebuild56
2 files changed, 0 insertions, 57 deletions
diff --git a/app-emulation/buildah/Manifest b/app-emulation/buildah/Manifest
index fcd943696906..502d06017e50 100644
--- a/app-emulation/buildah/Manifest
+++ b/app-emulation/buildah/Manifest
@@ -1,2 +1 @@
-DIST buildah-1.1.tar.gz 4253820 BLAKE2B ae30a677a2f569d87da0ab85732078912598cf25f7b22ad25540f5d89797983a8549eef1bc8d151d4e0be078b97e024df145bb882bdd8443becb07774bfb5875 SHA512 9957590d7413436195307746682496616fd2350b832242f33fb4cb07c1144addae445eeff062f403d26a68329f1153468489032bc9bbcf870839c760a720ef95
DIST buildah-1.2.tar.gz 4403310 BLAKE2B df3a1d12a41e9d585d3191103140fc232a2c247283996f394bd151f61615057b15d934e165be47794465c30217c32b3e6b53fbf4d2ef5a2f3349840dadad8171 SHA512 0aac0a80c3c50f0171199e549c0321ce1a756ca838dd9d92b0b0d58bd6b4e212390642c8a4a2aea794616292058624ab0c8707d2ea0cdcbcc555b387df611dc2
diff --git a/app-emulation/buildah/buildah-1.1.ebuild b/app-emulation/buildah/buildah-1.1.ebuild
deleted file mode 100644
index 3be0b76e6b5f..000000000000
--- a/app-emulation/buildah/buildah-1.1.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit bash-completion-r1 golang-vcs-snapshot
-
-KEYWORDS="~amd64"
-DESCRIPTION="A tool that facilitates building OCI images"
-HOMEPAGE="https://github.com/projectatomic/buildah"
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="ostree selinux"
-EGO_PN="${HOMEPAGE#*//}"
-EGIT_COMMIT="v${PV}"
-GIT_COMMIT="fbf46d3"
-SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
-RDEPEND="app-crypt/gpgme:=
- app-emulation/skopeo
- dev-libs/libgpg-error:=
- dev-libs/libassuan:=
- sys-fs/lvm2:=
- sys-libs/libseccomp:=
- selinux? ( sys-libs/libselinux:= )"
-DEPEND="${RDEPEND}"
-RESTRICT="test"
-REQUIRED_USE="!selinux? ( !ostree )"
-S="${WORKDIR}/${P}/src/${EGO_PN}"
-
-src_prepare() {
- default
- sed -e 's|^\(GIT_COMMIT := \).*|\1'${GIT_COMMIT}'|' -i Makefile || die
-
- [[ -f ostree_tag.sh ]] || die
- use ostree || { echo -e "#!/bin/sh\necho containers_image_ostree_stub" > \
- ostree_tag.sh || die; }
-
- [[ -f selinux_tag.sh ]] || die
- use selinux || { echo -e "#!/bin/sh\ntrue" > \
- selinux_tag.sh || die; }
-}
-
-src_compile() {
- GOPATH="${WORKDIR}/${P}" emake all
-}
-
-src_install() {
- dodoc CHANGELOG.md CONTRIBUTING.md README.md
- doman docs/*.1
- dodoc -r docs/tutorials
- dobin ${PN} imgtype
- dobashcomp contrib/completions/bash/buildah
-}
-
-src_test() {
- GOPATH="${WORKDIR}/${P}" emake test-unit
-}