summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephan Hartmann <sultan@gentoo.org>2022-05-07 16:04:04 +0200
committerStephan Hartmann <sultan@gentoo.org>2022-05-07 16:04:19 +0200
commitc45b8d9ddd2c936f047196ad8d0157df68ad85ac (patch)
treecce40e768dab13a8200ad8ee7653395b05469ce0
parentwww-apps/miniflux: restrict tests (diff)
downloadgentoo-c45b8d9d.tar.gz
gentoo-c45b8d9d.tar.bz2
gentoo-c45b8d9d.zip
net-misc/croc: add 9.5.5
Signed-off-by: Stephan Hartmann <sultan@gentoo.org>
-rw-r--r--net-misc/croc/Manifest1
-rw-r--r--net-misc/croc/croc-9.5.5.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/net-misc/croc/Manifest b/net-misc/croc/Manifest
index c71ec91ddc6a..42dde757358f 100644
--- a/net-misc/croc/Manifest
+++ b/net-misc/croc/Manifest
@@ -1,2 +1,3 @@
DIST croc-9.5.2.tar.gz 2833379 BLAKE2B de4623932b03b2c882bfa3f31aba45a6cf6383853a429a1bf5f28330ac8ca264fc3bffb9097c2eb2bc4ec3a8ba1a2ea2fe120cb0da2f6a5adf0180150b73e002 SHA512 d407379da195a0fb69b3fdd2b220e3c700d16380e495a30012628e08e5876cccb09ce3eb285285a1c4c63bfe08d0f7c3d6d64d28edc5332b0f4cd6c87b90a0f3
DIST croc-9.5.3.tar.gz 2847753 BLAKE2B 7ba9f321f3e6edb3e9332ca1e71ef3bcd9ec96ec2040ea00b861e5caa4427035ac4ffd1fbb01ebd944cd77f37e52789f2d6f0fe589646725b25ef2c59a4668e1 SHA512 b4f237af9d36cdf72b993ebbfcb9502f13f383d45888057394a9fe78ac778eefbf9a61268df6e584e8880879195ab1f30cf59ff2b74bfdd16b1d451c8670af5d
+DIST croc-9.5.5.tar.gz 2868323 BLAKE2B 52fda421cca32ec2f1f45f0df8e38e44c7dbb161856f9624665816b60957f5906ec01b4bdb0efd769974d2eed6f423adf987397a2e6e064e48382286d5c602a2 SHA512 7bb4f23dc6b0f809da87d67b10cfb1530cb138a3a70c9578b35de602ddf90cd0f61c2ba643a83d990890a07de29588b1387b83ac63b8eac2a75620a221330eb8
diff --git a/net-misc/croc/croc-9.5.5.ebuild b/net-misc/croc/croc-9.5.5.ebuild
new file mode 100644
index 000000000000..03dce788293d
--- /dev/null
+++ b/net-misc/croc/croc-9.5.5.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 go-module systemd
+
+DESCRIPTION="Easily and securely send things from one computer to another"
+HOMEPAGE="https://github.com/schollz/croc"
+
+SRC_URI="https://github.com/schollz/croc/releases/download/v${PV}/${PN}_${PV}_src.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD BSD-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ acct-group/croc
+ acct-user/croc
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-disable-network-tests-r1.patch"
+)
+
+DOCS=( README.md )
+
+src_prepare() {
+ default
+ # Replace User=nobody with User=croc
+ sed -i -e "s|\(^User=\).*|\1croc|g" croc.service || die
+ # Rename bash completion function
+ sed -i -e "s|_cli_bash_autocomplete|_croc|g" \
+ src/install/bash_autocomplete || die
+}
+
+src_compile() {
+ ego build
+}
+
+src_install() {
+ dobin croc
+ systemd_dounit croc.service
+ newbashcomp src/install/bash_autocomplete croc
+ einstalldocs
+}
+
+src_test() {
+ ego test -work ./...
+}