summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-07-17 17:57:54 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-07-23 13:21:01 +0200
commitc4859473944244496cbd0b28f5fb525a4a930e4b (patch)
treeb18f7190de86502f1c03e82241fb0f8e5d61634f
parentqt5-build.eclass: Support sed regardless if $MAKE is quoted or not (diff)
downloadgentoo-c4859473.tar.gz
gentoo-c4859473.tar.bz2
gentoo-c4859473.zip
dev-qt/qtcore: Fix configure w/ slibtool
Closes: https://bugs.gentoo.org/792804 Package-Manager: Portage-3.0.32, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-qt/qtcore/files/qtcore-5.15.5-slibtool.patch29
-rw-r--r--dev-qt/qtcore/qtcore-5.15.5-r2.ebuild2
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-qt/qtcore/files/qtcore-5.15.5-slibtool.patch b/dev-qt/qtcore/files/qtcore-5.15.5-slibtool.patch
new file mode 100644
index 000000000000..a7ae5702cb4d
--- /dev/null
+++ b/dev-qt/qtcore/files/qtcore-5.15.5-slibtool.patch
@@ -0,0 +1,29 @@
+From beebf54552e85c07496aa748710df76131620834 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Sun, 17 Jul 2022 17:43:27 +0200
+Subject: [PATCH] Remove quoting around $MAKE call
+
+Fixes build with e.g. MAKE='make libtool=...'
+
+Gentoo-bug: https://bugs.gentoo.org/792804
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ configure | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure b/configure
+index b6c9b462..096706b0 100755
+--- a/configure
++++ b/configure
+@@ -795,7 +795,7 @@ setBootstrapVariable()
+
+ if [ "$OPT_VERBOSE" = yes ]; then
+ # Show the output of make
+- (cd "$outpath/qmake"; "$MAKE") || exit 2
++ (cd "$outpath/qmake"; $MAKE) || exit 2
+ else
+ # Hide the output of make
+ # Use bash to print dots, if we have it, and stdout is a tty.
+--
+2.35.1
+
diff --git a/dev-qt/qtcore/qtcore-5.15.5-r2.ebuild b/dev-qt/qtcore/qtcore-5.15.5-r2.ebuild
index 2b2d3b2fe2b5..e86b12357c55 100644
--- a/dev-qt/qtcore/qtcore-5.15.5-r2.ebuild
+++ b/dev-qt/qtcore/qtcore-5.15.5-r2.ebuild
@@ -61,6 +61,8 @@ src_prepare() {
# fix missing qt_version_tag symbol w/ LTO, bug 674382
sed -i -e 's/^gcc:ltcg/gcc/' src/corelib/global/global.pri || die
+ eapply "${FILESDIR}/${P}-slibtool.patch" # bug 792804, TODO: merge into _QT5_GENTOOPATCHSET_REV
+
qt5-build_src_prepare
}