summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-01-21 11:22:07 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-01-21 11:22:42 +0100
commitc48b66e77c4e35cef27814870fd397fd4a04a6a8 (patch)
treed6a4562a9037fe0525de81e8b2a436da91ae2848
parentmedia-libs/libdvdnav: Bump to version 6.0.0 (diff)
downloadgentoo-c48b66e77c4e35cef27814870fd397fd4a04a6a8.tar.gz
gentoo-c48b66e77c4e35cef27814870fd397fd4a04a6a8.tar.bz2
gentoo-c48b66e77c4e35cef27814870fd397fd4a04a6a8.zip
media-libs/libdvdnav: Synced live ebuild.
Package-Manager: Portage-2.3.20, Repoman-2.3.6
-rw-r--r--media-libs/libdvdnav/libdvdnav-9999.ebuild30
1 files changed, 22 insertions, 8 deletions
diff --git a/media-libs/libdvdnav/libdvdnav-9999.ebuild b/media-libs/libdvdnav/libdvdnav-9999.ebuild
index af3c795d7a55..61b7dbaa549a 100644
--- a/media-libs/libdvdnav/libdvdnav-9999.ebuild
+++ b/media-libs/libdvdnav/libdvdnav-9999.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-AUTOTOOLS_AUTORECONF=1
-AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
-inherit autotools-multilib
+EAPI=6
+
+inherit autotools multilib-minimal
DESCRIPTION="Library for DVD navigation tools"
HOMEPAGE="https://www.videolan.org/developers/libdvdnav.html"
@@ -20,10 +19,25 @@ LICENSE="GPL-2"
SLOT="0"
IUSE="static-libs"
-RDEPEND=">=media-libs/libdvdread-5.0.2[${MULTILIB_USEDEP}]
- abi_x86_32? ( !<=app-emulation/emul-linux-x86-medialibs-20130224-r4
- !app-emulation/emul-linux-x86-medialibs[-abi_x86_32(-)] )"
+RDEPEND=">=media-libs/libdvdread-5.0.3[${MULTILIB_USEDEP}]"
DEPEND="${RDEPEND}
virtual/pkgconfig" # To get pkg.m4 for eautoreconf #414391
DOCS=( AUTHORS ChangeLog doc/dvd_structures doc/library_layout README TODO )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --enable-shared
+ $(use_enable static-libs static)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ find "${ED}" -name "*.la" -delete || die
+}