summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@cold-front.org>2020-09-29 16:29:26 -0400
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-10-02 23:19:20 -0700
commitc48cfb265e5607474be746056ebf85657da6bee2 (patch)
tree013d719576265c88786bbc66fcdb5834d6883563
parentdev-perl/AutoXS-Header: Cleanup old 1.20.0-r1 (diff)
downloadgentoo-c48cfb26.tar.gz
gentoo-c48cfb26.tar.bz2
gentoo-c48cfb26.zip
dev-vcs/tig: restore tab completion
The patch applied in the last bump is incorrect and effectively disables bash completion no matter what order the completions were loaded in as `type -f` will not find `__git_complete`. ``` $ type -f __git_complete bash: type: __git_complete: not found $ type __git_complete | grep 'is a' __git_complete is a function ``` There is a pull-request upstream that properly addresses the issue of `__git_complete` not being found but it's not accepted yet, https://github.com/jonas/tig/pull/1016 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Justin Bronder <jsbronder@cold-front.org> Closes: https://github.com/gentoo/gentoo/pull/17715 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-rw-r--r--dev-vcs/tig/files/tig-2.5.1-bash-completion-qa-warning.patch15
-rw-r--r--dev-vcs/tig/tig-2.5.1.ebuild4
2 files changed, 0 insertions, 19 deletions
diff --git a/dev-vcs/tig/files/tig-2.5.1-bash-completion-qa-warning.patch b/dev-vcs/tig/files/tig-2.5.1-bash-completion-qa-warning.patch
deleted file mode 100644
index 01222ddf14c9..000000000000
--- a/dev-vcs/tig/files/tig-2.5.1-bash-completion-qa-warning.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff --git a/contrib/tig-completion.bash b/contrib/tig-completion.bash
-index 5aef3fd..cec0632 100755
---- a/contrib/tig-completion.bash
-+++ b/contrib/tig-completion.bash
-@@ -29,6 +29,10 @@
- # at source time then all lookups will be done on demand,
- # which may be slightly slower.
-
-+if ! type -f __git_complete &>/dev/null; then
-+ __git_complete() { complete "${1}"; }
-+fi
-+
- __tig_options="
- -v --version
- -h --help
diff --git a/dev-vcs/tig/tig-2.5.1.ebuild b/dev-vcs/tig/tig-2.5.1.ebuild
index 41544b59209a..e88d7e4b44f3 100644
--- a/dev-vcs/tig/tig-2.5.1.ebuild
+++ b/dev-vcs/tig/tig-2.5.1.ebuild
@@ -31,10 +31,6 @@ RDEPEND="${DEPEND}
# encoding/env issues
RESTRICT="test"
-PATCHES=(
- "${FILESDIR}/tig-2.5.1-bash-completion-qa-warning.patch"
-)
-
src_prepare() {
default
[[ ${PV} == "9999" ]] && eautoreconf