summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2017-11-13 00:37:21 -0500
committerAnthony G. Basile <blueness@gentoo.org>2017-11-13 00:38:05 -0500
commitc49fa4f01ef4ddfb471a47ae5cffb4a7e29bc51e (patch)
tree1bb35e6d3138eba23947a358b5747fbbf3ea1503
parentapp-emulation/qemu-guest-agent: ebuild maintenance (diff)
downloadgentoo-c49fa4f0.tar.gz
gentoo-c49fa4f0.tar.bz2
gentoo-c49fa4f0.zip
net-misc/nyx: initial commit
Nyx is a command-line application for monitoring real time Tor status information. This includes bandwidth usage, logs, connections, configuration, and more. Package-Manager: Portage-2.3.8, Repoman-2.3.3
-rw-r--r--net-misc/nyx/Manifest1
-rw-r--r--net-misc/nyx/metadata.xml11
-rw-r--r--net-misc/nyx/nyx-2.0.4.ebuild22
3 files changed, 34 insertions, 0 deletions
diff --git a/net-misc/nyx/Manifest b/net-misc/nyx/Manifest
new file mode 100644
index 000000000000..7bc88561871f
--- /dev/null
+++ b/net-misc/nyx/Manifest
@@ -0,0 +1 @@
+DIST nyx-2.0.4.tar.gz 4074259 SHA256 38db634789c2d72e485522a490397eb5f77c0bd7c689453efe57808c99dba75e SHA512 bb64b6c38bbfc9837215503a69b4a6b7a11b8a1e230f42c51a405472689a3d46d74dd06b2417c90512b63e9605b33198c5132b660f9eca037016a39c5e4f0ecf WHIRLPOOL 7984eb45f3c22f217c1bf6b42402be978eabe128416e9dd2351f47117afd308258be2385705f2eeea6a703348c5872b748b0ffa8f8a47fa2f8c92e8d220631e2
diff --git a/net-misc/nyx/metadata.xml b/net-misc/nyx/metadata.xml
new file mode 100644
index 000000000000..7407400b590a
--- /dev/null
+++ b/net-misc/nyx/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>blueness@gentoo.org</email>
+ <name>Anthony G. Basile</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">nyx</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-misc/nyx/nyx-2.0.4.ebuild b/net-misc/nyx/nyx-2.0.4.ebuild
new file mode 100644
index 000000000000..93d2f04eb224
--- /dev/null
+++ b/net-misc/nyx/nyx-2.0.4.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+
+inherit vcs-snapshot distutils-r1
+
+DESCRIPTION="Utility to monitor real time Tor status information"
+HOMEPAGE="https://nyx.torproject.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ net-libs/stem
+ net-vpn/tor"