summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-01-24 18:28:31 +0100
committerDavid Seifert <soap@gentoo.org>2021-01-24 18:28:31 +0100
commitc4ad2874f40776743be9efbaf2ab5b33a34482b9 (patch)
tree0caab2e8c49b07b93d2a5972fe53b1e6c4dba444
parentapp-portage/portpeek: Switch to non-complex find. Version bump (diff)
downloadgentoo-c4ad2874f40776743be9efbaf2ab5b33a34482b9.tar.gz
gentoo-c4ad2874f40776743be9efbaf2ab5b33a34482b9.tar.bz2
gentoo-c4ad2874f40776743be9efbaf2ab5b33a34482b9.zip
app-crypt/libnitrokey: Version bump to 3.6
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--app-crypt/libnitrokey/Manifest1
-rw-r--r--app-crypt/libnitrokey/libnitrokey-3.6.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/app-crypt/libnitrokey/Manifest b/app-crypt/libnitrokey/Manifest
index abed557f9936..0a7271fec1e5 100644
--- a/app-crypt/libnitrokey/Manifest
+++ b/app-crypt/libnitrokey/Manifest
@@ -1 +1,2 @@
DIST libnitrokey-3.5.tar.gz 94356 BLAKE2B 9e53213f309e903d26e0e8e01ab213d6bc42c5b8d720e4b19f27adb607f20ad0c6e1707bf7b55c525efbd6a4fbf7b9c87983decf6b05dab7d03701ae0ea8277f SHA512 d2a95071e92d839c8cde4ac1435158bb469c25662f2988a4e824dbc0dfe83af841e6d04589293deddd77746dbec17b30c50fab69af58cc727ed5e0f2dbd0b5e7
+DIST libnitrokey-3.6.tar.gz 98038 BLAKE2B 27f99e7b6de93548fc7a373f37ce784da0aa50503a5c635b4d90282e6330a5ff4c0dcc03a83a7e57045b8a1aabaab27d76a090d7c49693a6ff1037b81e75ece9 SHA512 a00a6724e5c64715eca688ec254efd979acceb5ff4cad28a205f7128e44db8674a5924634fd7da6c69d589deafca7b28b99e1d05a244c321d5cb429f2e5a3bec
diff --git a/app-crypt/libnitrokey/libnitrokey-3.6.ebuild b/app-crypt/libnitrokey/libnitrokey-3.6.ebuild
new file mode 100644
index 000000000000..8687d0d1b4e3
--- /dev/null
+++ b/app-crypt/libnitrokey/libnitrokey-3.6.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit udev cmake
+
+DESCRIPTION="Support library for the Nitrokey"
+HOMEPAGE="https://github.com/Nitrokey/libnitrokey"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Nitrokey/libnitrokey.git"
+
+ # Disable pulling in bundled dependencies
+ EGIT_SUBMODULES=()
+else
+ SRC_URI="https://github.com/Nitrokey/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/hidapi:=
+ virtual/udev"
+DEPEND="
+ ${RDEPEND}
+ test? ( >=dev-cpp/catch-2.5.0:0 )"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_UDEVRULESDIR="$(get_udevdir)"/rules.d
+
+ # actual hardware tests
+ # 1. require a connected Nitrokey
+ # 2. may kill data on your Nitrokey
+ # hence the main testsuite is disabled
+ -DCOMPILE_TESTS=OFF
+ -DCOMPILE_OFFLINE_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}