summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2023-04-03 10:47:14 -0400
committerMike Gilbert <floppym@gentoo.org>2023-04-03 10:47:46 -0400
commitc4d457bd94c24853e0f6fe5ad3551f9407edde79 (patch)
tree59617f722a9c2ac61f4944f25c39c2cf8cb7141d
parentdev-util/meson: add 1.1.0_rc2, drop 1.1.0_rc1 (diff)
downloadgentoo-c4d457bd94c24853e0f6fe5ad3551f9407edde79.tar.gz
gentoo-c4d457bd94c24853e0f6fe5ad3551f9407edde79.tar.bz2
gentoo-c4d457bd94c24853e0f6fe5ad3551f9407edde79.zip
dev-libs/libgcrypt: enable munging of -Oz
Closes: https://bugs.gentoo.org/902765 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
-rw-r--r--dev-libs/libgcrypt/files/libgcrypt-1.10-build-Allow-build-with-Oz.patch50
-rw-r--r--dev-libs/libgcrypt/libgcrypt-1.10.1-r3.ebuild1
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-libs/libgcrypt/files/libgcrypt-1.10-build-Allow-build-with-Oz.patch b/dev-libs/libgcrypt/files/libgcrypt-1.10-build-Allow-build-with-Oz.patch
new file mode 100644
index 000000000000..c54499e15dba
--- /dev/null
+++ b/dev-libs/libgcrypt/files/libgcrypt-1.10-build-Allow-build-with-Oz.patch
@@ -0,0 +1,50 @@
+https://bugs.gentoo.org/902765
+https://dev.gnupg.org/T6432
+https://dev.gnupg.org/rC7edf1abb9a0d892a80cbf7ab42f64b2720671ee9
+
+From 7edf1abb9a0d892a80cbf7ab42f64b2720671ee9 Mon Sep 17 00:00:00 2001
+From: NIIBE Yutaka <gniibe@fsij.org>
+Date: Mon, 3 Apr 2023 14:00:15 +0900
+Subject: [PATCH] build: Allow build with -Oz.
+
+* cipher/Makefile.am [ENABLE_O_FLAG_MUNGING]: Support -Oz.
+* random/Makefile.am [ENABLE_O_FLAG_MUNGING]: Support -Oz.
+
+--
+
+GnuPG-bug-id: 6432
+Signed-off-by: NIIBE Yutaka <gniibe@fsij.org>
+---
+ cipher/Makefile.am | 2 +-
+ random/Makefile.am | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/cipher/Makefile.am b/cipher/Makefile.am
+index cf1fbe85..e67b1ee2 100644
+--- a/cipher/Makefile.am
++++ b/cipher/Makefile.am
+@@ -165,7 +165,7 @@ gost-s-box$(EXEEXT_FOR_BUILD): gost-s-box.c
+
+
+ if ENABLE_O_FLAG_MUNGING
+-o_flag_munging = sed -e 's/-O\([2-9sg][2-9sg]*\)/-O1/' -e 's/-Ofast/-O1/g'
++o_flag_munging = sed -e 's/-O\([2-9sgz][2-9sgz]*\)/-O1/' -e 's/-Ofast/-O1/g'
+ else
+ o_flag_munging = cat
+ endif
+diff --git a/random/Makefile.am b/random/Makefile.am
+index af978570..0c935a05 100644
+--- a/random/Makefile.am
++++ b/random/Makefile.am
+@@ -56,7 +56,7 @@ jitterentropy-base.c jitterentropy.h jitterentropy-base-user.h
+
+ # The rndjent module needs to be compiled without optimization. */
+ if ENABLE_O_FLAG_MUNGING
+-o_flag_munging = sed -e 's/-O\([1-9sg][1-9sg]*\)/-O0/g' -e 's/-Ofast/-O0/g'
++o_flag_munging = sed -e 's/-O\([1-9sgz][1-9sgz]*\)/-O0/g' -e 's/-Ofast/-O0/g'
+ else
+ o_flag_munging = cat
+ endif
+--
+2.40.0
+
diff --git a/dev-libs/libgcrypt/libgcrypt-1.10.1-r3.ebuild b/dev-libs/libgcrypt/libgcrypt-1.10.1-r3.ebuild
index 2d2497903a5b..d21cd0309fdb 100644
--- a/dev-libs/libgcrypt/libgcrypt-1.10.1-r3.ebuild
+++ b/dev-libs/libgcrypt/libgcrypt-1.10.1-r3.ebuild
@@ -47,6 +47,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.10.1-fix-no-asm-hppa.patch
"${FILESDIR}"/${PN}-1.9.4-no-fgrep-libgcrypt-config.patch
"${FILESDIR}"/${PN}-1.10.1-configure-clang16.patch
+ "${FILESDIR}"/libgcrypt-1.10-build-Allow-build-with-Oz.patch
)
MULTILIB_CHOST_TOOLS=(