summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-10-03 07:58:00 +0200
committerHans de Graaff <graaff@gentoo.org>2016-10-03 07:58:00 +0200
commitc4dd1cbc937fc94b1f2b5783406faf93b0b5f460 (patch)
tree00b309ac15a304534305eeb872d5ee6f79eee8f6
parentdev-ruby/rspec-core: add 3.5.4 (diff)
downloadgentoo-c4dd1cbc937fc94b1f2b5783406faf93b0b5f460.tar.gz
gentoo-c4dd1cbc937fc94b1f2b5783406faf93b0b5f460.tar.bz2
gentoo-c4dd1cbc937fc94b1f2b5783406faf93b0b5f460.zip
dev-ruby/ruby-vte3: Depend on correct vte slot, fixing bug 595894
Package-Manager: portage-2.3.0
-rw-r--r--dev-ruby/ruby-vte3/ruby-vte3-3.0.7-r1.ebuild42
-rw-r--r--dev-ruby/ruby-vte3/ruby-vte3-3.0.8-r1.ebuild42
2 files changed, 84 insertions, 0 deletions
diff --git a/dev-ruby/ruby-vte3/ruby-vte3-3.0.7-r1.ebuild b/dev-ruby/ruby-vte3/ruby-vte3-3.0.7-r1.ebuild
new file mode 100644
index 000000000000..788f5e5f4457
--- /dev/null
+++ b/dev-ruby/ruby-vte3/ruby-vte3-3.0.7-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22"
+
+inherit virtualx ruby-ng-gnome2
+
+DESCRIPTION="Ruby VTE bindings"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND+=" x11-libs/vte:2.91"
+RDEPEND+=" x11-libs/vte:2.91"
+
+ruby_add_bdepend ">=dev-ruby/ruby-glib2-${PV}"
+ruby_add_rdepend ">=dev-ruby/ruby-gtk3-${PV}"
+
+all_ruby_prepare() {
+ sed -i -e '/system/,/^ end/ s:^:#:' test/run-test.rb || die
+
+ # Avoid tests that require a real pty.
+ rm -f test/test-pty.rb || die
+}
+
+each_ruby_configure() {
+ :
+}
+
+each_ruby_compile() {
+ :
+}
+
+each_ruby_test() {
+ VIRTUALX_COMMAND="${RUBY} test/run-test.rb"
+ virtualmake || die
+}
+
+each_ruby_install() {
+ each_fakegem_install
+}
diff --git a/dev-ruby/ruby-vte3/ruby-vte3-3.0.8-r1.ebuild b/dev-ruby/ruby-vte3/ruby-vte3-3.0.8-r1.ebuild
new file mode 100644
index 000000000000..d92e003c8b12
--- /dev/null
+++ b/dev-ruby/ruby-vte3/ruby-vte3-3.0.8-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23"
+
+inherit virtualx ruby-ng-gnome2
+
+DESCRIPTION="Ruby VTE bindings"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND+=" x11-libs/vte:2.91"
+RDEPEND+=" x11-libs/vte:2.91"
+
+ruby_add_bdepend ">=dev-ruby/ruby-glib2-${PV}"
+ruby_add_rdepend ">=dev-ruby/ruby-gtk3-${PV}"
+
+all_ruby_prepare() {
+ sed -i -e '/system/,/^ end/ s:^:#:' test/run-test.rb || die
+
+ # Avoid tests that require a real pty.
+ rm -f test/test-pty.rb || die
+}
+
+each_ruby_configure() {
+ :
+}
+
+each_ruby_compile() {
+ :
+}
+
+each_ruby_test() {
+ VIRTUALX_COMMAND=${RUBY}
+ virtualmake test/run-test.rb || die
+}
+
+each_ruby_install() {
+ each_fakegem_install
+}