summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-29 10:34:25 +0100
committerSam James <sam@gentoo.org>2022-04-29 11:20:51 +0100
commitc50fbe69df83401d6806c2f29ee302d961e630d4 (patch)
tree2929214b7e149a9214115f66da8dd0e9a8e21b7c
parentdev-util/git-delta: drop 0.12.0 (diff)
downloadgentoo-c50fbe69.tar.gz
gentoo-c50fbe69.tar.bz2
gentoo-c50fbe69.zip
dev-util/pkgconf: drop 1.7.4-r1
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-util/pkgconf/Manifest1
-rw-r--r--dev-util/pkgconf/pkgconf-1.7.4-r1.ebuild74
2 files changed, 0 insertions, 75 deletions
diff --git a/dev-util/pkgconf/Manifest b/dev-util/pkgconf/Manifest
index af60a22e7dfc..5a9d1dca32cd 100644
--- a/dev-util/pkgconf/Manifest
+++ b/dev-util/pkgconf/Manifest
@@ -1,2 +1 @@
-DIST pkgconf-1.7.4.tar.xz 293888 BLAKE2B af814174b59e3ea7009230f639a6237226caafb22300946904dd10810c0b5cfcbfeea21767a3a1d2c2b5cb1fe4b7b1d995a52d820fcfce3adb383c66762b7576 SHA512 92c080684898b42824a1f1a7e3ce8a600896fc9c20fcf263f032b856fa4c7139607f87ba44d18ed358b8c5f4f04477708800d20a4e10f96e4268a55682f7f0c1
DIST pkgconf-1.8.0.tar.xz 296304 BLAKE2B 6585a855a313406f77d26fba3cc3cef798b27c4b7ece81738bdba12f36ee93fbcaf838e1065406c28adc20852e34e2de14bc5f4837982f9cc35360d9a3ac83a5 SHA512 58204006408ad5ce91222ed3c93c2e0b61c04fa83c0a8ad337b747b583744578dbebd4ad5ccbc577689637caa1c5dc246b7795ac46e39c6666b1aa78199b7c28
diff --git a/dev-util/pkgconf/pkgconf-1.7.4-r1.ebuild b/dev-util/pkgconf/pkgconf-1.7.4-r1.ebuild
deleted file mode 100644
index b174cb7572a4..000000000000
--- a/dev-util/pkgconf/pkgconf-1.7.4-r1.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 2012-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit multilib multilib-minimal
-
-if [[ ${PV} == "9999" ]] ; then
- inherit autotools git-r3
- EGIT_REPO_URI="https://git.sr.ht/~kaniini/pkgconf"
-else
- SRC_URI="http://distfiles.dereferenced.org/${PN}/${P}.tar.xz"
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~ppc-macos ~x64-macos"
-fi
-
-DESCRIPTION="pkg-config compatible replacement with no dependencies other than ANSI C89"
-HOMEPAGE="https://git.sr.ht/~kaniini/pkgconf"
-
-LICENSE="ISC"
-SLOT="0/3"
-IUSE="test"
-
-# tests require 'kyua'
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- test? (
- dev-libs/atf
- dev-util/kyua
- )
-"
-RDEPEND="
- !dev-util/pkgconfig
-"
-
-MULTILIB_CHOST_TOOLS=(
- /usr/bin/pkgconf$(get_exeext)
-)
-
-src_prepare() {
- default
-
- [[ ${PV} == "9999" ]] && eautoreconf
- MULTILIB_CHOST_TOOLS+=(
- /usr/bin/pkg-config$(get_exeext)
- )
-}
-
-multilib_src_configure() {
- local ECONF_SOURCE="${S}"
- local args=(
- --disable-static
- --with-system-includedir="${EPREFIX}/usr/include"
- --with-system-libdir="${EPREFIX}/$(get_libdir):${EPREFIX}/usr/$(get_libdir)"
- )
- econf "${args[@]}"
-}
-
-multilib_src_test() {
- unset PKG_CONFIG_LIBDIR PKG_CONFIG_PATH
- default
-}
-
-multilib_src_install() {
- default
-
- dosym pkgconf$(get_exeext) /usr/bin/pkg-config$(get_exeext)
- dosym pkgconf.1 /usr/share/man/man1/pkg-config.1
-}
-
-multilib_src_install_all() {
- einstalldocs
- find "${ED}" -type f -name '*.la' -delete || die
-}