summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-16 17:26:45 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-16 17:28:29 +0200
commitc513d71bbabb4248fc06645dec2daa24d618bbcd (patch)
tree52f5862b41e3162551af531d07f14c87843cc21c
parentdev-python/transitions: Bump to 0.9.1 (diff)
downloadgentoo-c513d71bbabb4248fc06645dec2daa24d618bbcd.tar.gz
gentoo-c513d71bbabb4248fc06645dec2daa24d618bbcd.tar.bz2
gentoo-c513d71bbabb4248fc06645dec2daa24d618bbcd.zip
dev-python/gpep517: Bump to 16
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/gpep517/Manifest1
-rw-r--r--dev-python/gpep517/gpep517-16.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/gpep517/Manifest b/dev-python/gpep517/Manifest
index 457730369753..05aa9bf9fda7 100644
--- a/dev-python/gpep517/Manifest
+++ b/dev-python/gpep517/Manifest
@@ -1 +1,2 @@
DIST gpep517-15.gh.tar.gz 17535 BLAKE2B 265c2392cc70f4a94f6b8329dbba0ec5eb821e687bba553009bdc5e230d856fe6f105c873a79ee7ca99fb75c072c3d3c3b4f716ca873d13a8e393b33a97c8540 SHA512 7c3b878220e907ef801301eadc0e3031dd3c31770cc50bb7119ab32f9244c8a33792b4896ddeffc5d4b7be9f1d881fba5179de155f11845f510e455be59fb92e
+DIST gpep517-16.gh.tar.gz 23951 BLAKE2B 9be3bf7845f85b756444e5699509cf12455ea71204fb0e9a4899000cd2802cc063cd785f490d6e3d9ac48bf79a9e43a0edcfb483d898f718be6d783a98834cdd SHA512 fcd7cb0f98003a8ecb9976cffe3d4140b16e537dbfcfa8e8416569cd7e38e8e9ab359b35c1e22b830dc2711b3c07f8e3113c0f6b73d415ce63ad5f7d76f180c6
diff --git a/dev-python/gpep517/gpep517-16.ebuild b/dev-python/gpep517/gpep517-16.ebuild
new file mode 100644
index 000000000000..30dbb097b1ca
--- /dev/null
+++ b/dev-python/gpep517/gpep517-16.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
+EAPI=8
+
+DISTUTILS_USE_PEP517=no
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="A backend script to aid installing Python packages in Gentoo"
+HOMEPAGE="
+ https://pypi.org/project/gpep517/
+ https://github.com/projg2/gpep517/
+"
+SRC_URI="
+ https://github.com/projg2/gpep517/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ >=dev-python/installer-0.5.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.2.3[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -o tmp_path_retention_policy=all
+}
+
+python_install() {
+ python_domodule gpep517
+ python_newscript - gpep517 <<-EOF
+ #!${EPREFIX}/usr/bin/python
+ import sys
+ from gpep517.__main__ import main
+ sys.exit(main())
+ EOF
+}