summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-25 22:03:28 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-25 22:03:28 +0300
commitc53242b52140719ab4de1388d7b7b5b8475bb160 (patch)
tree47017463362c53689a22af5c110885c64fba769c
parentdev-python/pyudev: add 0.24.0 (diff)
downloadgentoo-c53242b5.tar.gz
gentoo-c53242b5.tar.bz2
gentoo-c53242b5.zip
dev-python/jupyter_packaging: add 0.12.3
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/jupyter_packaging/Manifest1
-rw-r--r--dev-python/jupyter_packaging/jupyter_packaging-0.12.3.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/jupyter_packaging/Manifest b/dev-python/jupyter_packaging/Manifest
index 5f854383d2be..c9d1104f3a16 100644
--- a/dev-python/jupyter_packaging/Manifest
+++ b/dev-python/jupyter_packaging/Manifest
@@ -1 +1,2 @@
DIST jupyter_packaging-0.12.2.tar.gz 27990 BLAKE2B 0cd07fa760fe0bd4529e8430bd52863034cc4c78d8f906f55530a6825c496b8a1bf2fff76da3f4e963ee43c80fc19347edbaf20d16fbfe51584b040b0ab4d3ed SHA512 f4167c7beb3188d2e4b0fa8601fb8cdede8b20dc8c16e0bccbcf9e317e75e24ea1469a9d904bb35b2d81dec351caf49526ef35e5d91460a099a8e4ed6974e1b1
+DIST jupyter_packaging-0.12.3.tar.gz 25350 BLAKE2B 62c9f35a3008f8252f8ae8a55b2f7156fc98347b48dbe9bf08101b9c9b0cc892886cf248e0d916455f472bd5130dacccbfb9e206818c5f096eb759bb6149f758 SHA512 a81a4b41ba7b31b9d71aa338617ed8567100a64d999e6cd0a14586350bcd37bf9782cbaabad755c0303510bd342ec141af01157cbdc1e4373289700dfc40c3c9
diff --git a/dev-python/jupyter_packaging/jupyter_packaging-0.12.3.ebuild b/dev-python/jupyter_packaging/jupyter_packaging-0.12.3.ebuild
new file mode 100644
index 000000000000..60f174880fc1
--- /dev/null
+++ b/dev-python/jupyter_packaging/jupyter_packaging-0.12.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Tools to help build and install Jupyter Python packages"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/jupyter-packaging/
+ https://pypi.org/project/jupyter-packaging/
+"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-60.2.0[${PYTHON_USEDEP}]
+ dev-python/tomlkit[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ dev-python/deprecation[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/build[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # require Internet
+ tests/test_build_api.py::test_build_package
+ tests/test_build_api.py::test_deprecated_metadata
+)