summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-01-08 19:00:45 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-01-08 20:22:41 +0100
commitc54bcc90dce142ac8db068b92cd119dc64087c40 (patch)
tree0c12d4b45988d5be36253467de028f429205eaf6
parentapp-emacs/fsharp-mode: bump to 2.0_p20230622 (diff)
downloadgentoo-c54bcc90dce142ac8db068b92cd119dc64087c40.tar.gz
gentoo-c54bcc90dce142ac8db068b92cd119dc64087c40.tar.bz2
gentoo-c54bcc90dce142ac8db068b92cd119dc64087c40.zip
app-emacs/fsharp-mode: add live 9999 version
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-emacs/fsharp-mode/fsharp-mode-9999.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-emacs/fsharp-mode/fsharp-mode-9999.ebuild b/app-emacs/fsharp-mode/fsharp-mode-9999.ebuild
new file mode 100644
index 000000000000..77bff9ac449b
--- /dev/null
+++ b/app-emacs/fsharp-mode/fsharp-mode-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=29.1 # To compile full suite including Eglot, introduced in 29.1.
+
+inherit elisp
+
+DESCRIPTION="Support for the F# programming language"
+HOMEPAGE="https://github.com/fsharp/emacs-fsharp-mode/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/fsharp/emacs-${PN}.git"
+else
+ SRC_URI="https://github.com/fsharp/emacs-${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/emacs-${P}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+DOCS=( CHANGELOG.md README.org )
+ELISP_REMOVE="test/fsi-tests.el test/integration-tests.el"
+SITEFILE="50${PN}-gentoo.el"
+
+elisp-enable-tests buttercup test