summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2024-01-25 12:07:48 +0100
committerDavid Seifert <soap@gentoo.org>2024-01-25 12:07:48 +0100
commitc54cb04aac675eebda4970990d7fd073f0d56e40 (patch)
tree6d2a8c69e6cd067202bd79c38d08e9b48f325890
parentwww-apps/liquid_feedback_core: add 4.0.0 (diff)
downloadgentoo-c54cb04aac675eebda4970990d7fd073f0d56e40.tar.gz
gentoo-c54cb04aac675eebda4970990d7fd073f0d56e40.tar.bz2
gentoo-c54cb04aac675eebda4970990d7fd073f0d56e40.zip
net-fs/nfs-utils: remove USE={idmap,nfsdcld}
* The absence of idmap leads to obscure issues on NFSv4. Closes: https://github.com/gentoo/gentoo/pull/34988 Bug: https://bugs.gentoo.org/798831 Bug: https://bugs.gentoo.org/914203 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--net-fs/nfs-utils/nfs-utils-2.6.4-r3.ebuild (renamed from net-fs/nfs-utils/nfs-utils-2.6.4-r2.ebuild)23
1 files changed, 8 insertions, 15 deletions
diff --git a/net-fs/nfs-utils/nfs-utils-2.6.4-r2.ebuild b/net-fs/nfs-utils/nfs-utils-2.6.4-r3.ebuild
index bf04672be1de..ae1a7eca66e6 100644
--- a/net-fs/nfs-utils/nfs-utils-2.6.4-r2.ebuild
+++ b/net-fs/nfs-utils/nfs-utils-2.6.4-r3.ebuild
@@ -19,8 +19,8 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="caps junction kerberos ldap +libmount nfsdcld +nfsidmap +nfsv3 +nfsv4 sasl selinux tcpd +uuid"
-REQUIRED_USE="|| ( nfsv3 nfsv4 ) kerberos? ( nfsv4 ) nfsdcld? ( nfsv4 )"
+IUSE="caps junction kerberos ldap +libmount +nfsv3 +nfsv4 sasl selinux tcpd +uuid"
+REQUIRED_USE="|| ( nfsv3 nfsv4 ) kerberos? ( nfsv4 )"
# bug #315573
RESTRICT="test"
@@ -78,10 +78,9 @@ PATCHES=(
pkg_setup() {
linux-info_pkg_setup
- if use nfsv4 && ! use nfsdcld && linux_config_exists && ! linux_chkconfig_present CRYPTO_MD5 ; then
+ if use nfsv4 && linux_config_exists && ! linux_chkconfig_present CRYPTO_MD5 ; then
ewarn "Your NFS server will be unable to track clients across server restarts!"
- ewarn "Please enable the \"${HILITE}nfsdcld${NORMAL}\" USE flag to install the nfsdcltrack usermode"
- ewarn "helper upcall program, or enable ${HILITE}CONFIG_CRYPTO_MD5${NORMAL} in your kernel to"
+ ewarn "Please enable ${HILITE}CONFIG_CRYPTO_MD5${NORMAL} in your kernel to"
ewarn "support the legacy, in-kernel client tracker."
fi
}
@@ -99,7 +98,7 @@ src_prepare() {
src_configure() {
# Our DEPEND forces this.
export libsqlite3_cv_is_recent=yes
- export ac_cv_header_keyutils_h=$(usex nfsidmap)
+ export ac_cv_header_keyutils_h=$(usex nfsv4)
# SASL is consumed in a purely automagic way
export ac_cv_header_sasl_h=no
@@ -121,9 +120,9 @@ src_configure() {
$(use_enable kerberos svcgss)
$(use_enable ldap)
$(use_enable libmount libmount-mount)
- $(use_enable nfsdcld)
- $(use_enable nfsdcld nfsdcltrack)
$(use_enable nfsv4)
+ $(use_enable nfsv4 nfsdcld)
+ $(use_enable nfsv4 nfsdcltrack)
$(use_enable nfsv4 nfsv41)
$(use_enable nfsv4 nfsv4server)
$(use_enable uuid)
@@ -157,7 +156,7 @@ src_install() {
dodir /sbin
mv "${ED}"/usr/sbin/rpc.statd "${ED}"/sbin/ || die
- if use nfsv4 && use nfsidmap ; then
+ if use nfsv4 ; then
insinto /etc
doins support/nfsidmap/idmapd.conf
@@ -181,12 +180,6 @@ src_install() {
newinitd "${FILESDIR}"/${f}.initd ${f}
done
- # Nuke after 2015/08/01
- newinitd "${FILESDIR}"/nfsmount.initd-1.3.1 nfsmount
- for f in nfs nfsclient ; do
- newconfd "${FILESDIR}"/${f}.confd ${f}
- done
-
# bug #234132
sed -i \
-e "/^NFS_NEEDED_SERVICES=/s:=.*:=\"${opt_need}\":" \