summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-01-14 04:31:49 +0000
committerSam James <sam@gentoo.org>2024-01-14 04:31:49 +0000
commitc551cede5af40726167bd46c2a2fa2007bf20c36 (patch)
treee878cab4f3d3bf5e2663f25ce638bf1af9a78207
parentdev-debug/valgrind: Stabilize 3.21.0-r2 ppc64, #922067 (diff)
downloadgentoo-c551cede.tar.gz
gentoo-c551cede.tar.bz2
gentoo-c551cede.zip
net-misc/inetutils: add 2.5
Bug: https://bugs.gentoo.org/922073 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-misc/inetutils/Manifest1
-rw-r--r--net-misc/inetutils/inetutils-2.5.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/net-misc/inetutils/Manifest b/net-misc/inetutils/Manifest
index 81c1302e7a72..8684f9864b63 100644
--- a/net-misc/inetutils/Manifest
+++ b/net-misc/inetutils/Manifest
@@ -1 +1,2 @@
DIST inetutils-2.4.tar.xz 1558308 BLAKE2B 1f7a33f313b736b305f62587c727ba843659621fbd89610dea81a0acf0e74aca8d3005cca2e3451fe30517880678023d4949bf1b1276bb660b80802e97c06bc8 SHA512 e7e6a5d7e2e02f07a2a6cfc09694e3c0a4e4a8ef8a435eed41902eba13caeed329ae6d6ba94b0de8f789e307f04656d12c48c1c0217b69d162bc5efb0ff6adee
+DIST inetutils-2.5.tar.xz 1670424 BLAKE2B 80ab4f4287328ceb75c33b8794ec21209ea95206a205ea60fbd8f1d7e7fa01eec228ea50d61c8bb37a88cd3144b58ecfecd0af440ba85d43d5ea19565d88a6d4 SHA512 dc11ad6eeb5ea2c85edddbfc77630b5b09e4e1ac643629edf13b0ac0828c13cdb0885275153c072ae13a798427c96bc461037822ad646f7210369192c35bb04c
diff --git a/net-misc/inetutils/inetutils-2.5.ebuild b/net-misc/inetutils/inetutils-2.5.ebuild
new file mode 100644
index 000000000000..adc14e092684
--- /dev/null
+++ b/net-misc/inetutils/inetutils-2.5.ebuild
@@ -0,0 +1,86 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit pam
+
+DESCRIPTION="Collection of common network programs"
+HOMEPAGE="https://www.gnu.org/software/inetutils/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+SERVERS="ftpd inetd rexecd rlogind rshd syslogd talkd telnetd tftpd uucpd"
+CLIENTS="ftp dnsdomainname hostname ping ping6 rcp rexec rlogin rsh logger telnet tftp whois ifconfig traceroute"
+PROGRAMS="${SERVERS} ${CLIENTS}"
+IUSE="idn kerberos pam tcpd ${PROGRAMS}"
+
+DEPEND="
+ sys-libs/readline:0=
+ ftpd? ( virtual/libcrypt:0= )
+ idn? ( net-dns/libidn2:= )
+ kerberos? ( virtual/krb5 )
+ pam? ( sys-libs/pam )
+ tcpd? ( sys-apps/tcp-wrappers )
+ uucpd? ( virtual/libcrypt:0= )
+"
+RDEPEND="${DEPEND}
+ ftpd? ( net-ftp/ftpbase[pam?] )
+ ftp? ( !net-ftp/ftp )
+ dnsdomainname? ( !sys-apps/net-tools )
+ hostname? ( !sys-apps/coreutils[hostname(-)] !sys-apps/net-tools[hostname(+)] )
+ ping? ( !net-misc/iputils )
+ ping6? ( !net-misc/iputils[ipv6(+)] )
+ rcp? ( !net-misc/netkit-rsh )
+ rexec? ( !net-misc/netkit-rsh )
+ rlogin? ( !net-misc/netkit-rsh )
+ rsh? ( !net-misc/netkit-rsh )
+ logger? ( !sys-apps/util-linux[logger(+)] )
+ telnet? ( !net-misc/telnet-bsd !net-misc/netkit-telnetd )
+ tftp? ( !net-ftp/tftp-hpa )
+ whois? ( !net-misc/whois )
+ ifconfig? ( !sys-apps/net-tools )
+ traceroute? ( !net-analyzer/traceroute )
+"
+
+QA_CONFIG_IMPL_DECL_SKIP=( MIN static_assert alignof unreachable )
+
+src_configure() {
+ local myconf=(
+ --disable-clients
+ --disable-servers
+ $(use_with idn)
+ --without-krb4
+ $(use_with kerberos krb5)
+ --without-shishi
+ $(use_with pam)
+ $(use_with tcpd wrap)
+ )
+
+ local prog
+ for prog in ${PROGRAMS}; do
+ myconf+=( $(use_enable "${prog}") )
+ done
+
+ econf "${myconf[@]}"
+}
+
+iu_pamd() {
+ if use "$1"; then
+ pamd_mimic system-remote-login "$2" auth account password session
+ fi
+}
+
+src_install() {
+ default
+ iu_pamd rexecd rexec
+ iu_pamd rlogind rlogin
+ iu_pamd rshd rsh
+ if use kerberos; then
+ iu_pamd rlogind krlogin
+ iu_pamd rshd krsh
+ fi
+}