summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-01-05 13:24:08 +0000
committerSam James <sam@gentoo.org>2024-01-05 13:24:46 +0000
commitc552aae1e4c2dc88ad964fd4134505c2cdf0d26e (patch)
treee3fa9825337c95c119eeb4dd0db9bccf095311b2
parentdev-python/pycryptodome: fix configure w/ gcc 14 (diff)
downloadgentoo-c552aae1e4c2dc88ad964fd4134505c2cdf0d26e.tar.gz
gentoo-c552aae1e4c2dc88ad964fd4134505c2cdf0d26e.tar.bz2
gentoo-c552aae1e4c2dc88ad964fd4134505c2cdf0d26e.zip
dev-util/gperf: filter LTO, disable strict aliasing
Closes: https://bugs.gentoo.org/858377 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-util/gperf/gperf-3.1-r2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-util/gperf/gperf-3.1-r2.ebuild b/dev-util/gperf/gperf-3.1-r2.ebuild
new file mode 100644
index 000000000000..f5fd37924abf
--- /dev/null
+++ b/dev-util/gperf/gperf-3.1-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+DESCRIPTION="A perfect hash function generator"
+HOMEPAGE="https://www.gnu.org/software/gperf/"
+SRC_URI="mirror://gnu/gperf/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-strncmp-decl-mismatch.patch
+ "${FILESDIR}"/${P}-clang-16-wregister.patch
+ "${FILESDIR}"/${P}-parallel-tests.patch
+)
+
+src_prepare() {
+ sed -i \
+ -e "/^CPPFLAGS /s:=:+=:" \
+ */Makefile.in || die #444078
+
+ default
+}
+
+src_configure() {
+ # Aliasing violation (bug #858377)
+ append-flags -fno-strict-aliasing
+ filter-lto
+
+ econf --cache-file="${S}"/config.cache
+}