summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-08 10:58:40 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-08 11:54:24 +0200
commitc555dea2868f595dd9262d22a85c0323397406bb (patch)
tree9a4e8fe8262437278f6d63fa757e00b3a8e90496
parentgames-emulation/dolphin: Remove USE=lto (diff)
downloadgentoo-c555dea2868f595dd9262d22a85c0323397406bb.tar.gz
gentoo-c555dea2868f595dd9262d22a85c0323397406bb.tar.bz2
gentoo-c555dea2868f595dd9262d22a85c0323397406bb.zip
games-emulation/dolphin: USE={qt5 → gui}
The Qt5 GUI is the only supported GUI in the ebuild, so use the generic flag for it. Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--games-emulation/dolphin/dolphin-5.0_p20210506-r1.ebuild12
-rw-r--r--games-emulation/dolphin/dolphin-9999.ebuild12
2 files changed, 12 insertions, 12 deletions
diff --git a/games-emulation/dolphin/dolphin-5.0_p20210506-r1.ebuild b/games-emulation/dolphin/dolphin-5.0_p20210506-r1.ebuild
index 197f1a4d0863..c85cb41f4199 100644
--- a/games-emulation/dolphin/dolphin-5.0_p20210506-r1.ebuild
+++ b/games-emulation/dolphin/dolphin-5.0_p20210506-r1.ebuild
@@ -23,8 +23,8 @@ HOMEPAGE="https://www.dolphin-emu.org/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="alsa bluetooth discord-presence doc +evdev ffmpeg log
- profile pulseaudio +qt5 systemd upnp vulkan"
+IUSE="alsa bluetooth discord-presence doc +evdev ffmpeg +gui log
+ profile pulseaudio systemd upnp vulkan"
RDEPEND="
dev-libs/hidapi:0=
@@ -51,13 +51,13 @@ RDEPEND="
virtual/udev
)
ffmpeg? ( media-video/ffmpeg:= )
- profile? ( dev-util/oprofile )
- pulseaudio? ( media-sound/pulseaudio )
- qt5? (
+ gui? (
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtwidgets:5
)
+ profile? ( dev-util/oprofile )
+ pulseaudio? ( media-sound/pulseaudio )
systemd? ( sys-apps/systemd:0= )
upnp? ( net-libs/miniupnpc )
"
@@ -144,7 +144,7 @@ src_configure() {
# just adds -flto, user can do that via flags
-DENABLE_LTO=OFF
-DENABLE_PULSEAUDIO=$(usex pulseaudio)
- -DENABLE_QT=$(usex qt5)
+ -DENABLE_QT=$(usex gui)
-DENABLE_SDL=OFF # not supported: #666558
-DENABLE_VULKAN=$(usex vulkan)
-DFASTLOG=$(usex log)
diff --git a/games-emulation/dolphin/dolphin-9999.ebuild b/games-emulation/dolphin/dolphin-9999.ebuild
index 07bcced944c9..7842f809ac16 100644
--- a/games-emulation/dolphin/dolphin-9999.ebuild
+++ b/games-emulation/dolphin/dolphin-9999.ebuild
@@ -24,8 +24,8 @@ HOMEPAGE="https://www.dolphin-emu.org/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="alsa bluetooth discord-presence doc +evdev ffmpeg log mgba
- profile pulseaudio +qt5 systemd upnp vulkan"
+IUSE="alsa bluetooth discord-presence doc +evdev ffmpeg +gui log mgba
+ profile pulseaudio systemd upnp vulkan"
RDEPEND="
dev-libs/hidapi:0=
@@ -52,13 +52,13 @@ RDEPEND="
virtual/udev
)
ffmpeg? ( media-video/ffmpeg:= )
- profile? ( dev-util/oprofile )
- pulseaudio? ( media-sound/pulseaudio )
- qt5? (
+ gui? (
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtwidgets:5
)
+ profile? ( dev-util/oprofile )
+ pulseaudio? ( media-sound/pulseaudio )
systemd? ( sys-apps/systemd:0= )
upnp? ( net-libs/miniupnpc )
"
@@ -147,7 +147,7 @@ src_configure() {
-DENABLE_LTO=OFF
-DUSE_MGBA=$(usex mgba)
-DENABLE_PULSEAUDIO=$(usex pulseaudio)
- -DENABLE_QT=$(usex qt5)
+ -DENABLE_QT=$(usex gui)
-DENABLE_SDL=OFF # not supported: #666558
-DENABLE_VULKAN=$(usex vulkan)
-DFASTLOG=$(usex log)