summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-07 09:46:15 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-07 10:04:38 +0200
commitc55d32efc5ea16211f0c07e431c239e892dff43b (patch)
tree70aa7746142cea7b8c5f503afe1b0df70abfce58
parentdev-python/botocore: Bump to 1.20.68 (diff)
downloadgentoo-c55d32efc5ea16211f0c07e431c239e892dff43b.tar.gz
gentoo-c55d32efc5ea16211f0c07e431c239e892dff43b.tar.bz2
gentoo-c55d32efc5ea16211f0c07e431c239e892dff43b.zip
dev-python/boto3: Bump to 1.17.68
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.17.68.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 02c29b699950..0ec94059504a 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -3,3 +3,4 @@ DIST boto3-1.17.62.tar.gz 366832 BLAKE2B be452f1afe79538c29a9c8d8aaf0e0d0224a34b
DIST boto3-1.17.64.tar.gz 367357 BLAKE2B 582cc599628df29acdb146a0a1da78fb1e35d560f08f54709e5aed9fb27be9ffeaec27b1c2f393ddd48fad5b9c5ff5e51d001972a798b516e089d58d321aaac3 SHA512 ffe248707d162de5a2edd2dec4acb769bda3d2d0c9611548813647d3f0d70de9e6754216ba32df70eacf2e4a6ed2c8fab30261731aa87977eb5972af6052ddb4
DIST boto3-1.17.65.tar.gz 367905 BLAKE2B d6aa552a8f5a40613577dcb4d43de185662799f471eae2c14baee4799ac2ccc3b8a7c44e39bad8997b2c68d783c1e4454c0f94e41888a895f88bbc740905d626 SHA512 0bfdcba7fa15e0340b9bc235c4f3e09cd1e01d99b6fc7a95e7543723477b6d642ef2b833b24a5cd1adf2c274d517fe43ee0f9bdceac973b472227580fa39b29f
DIST boto3-1.17.67.tar.gz 368242 BLAKE2B 72e612816c45d49c74430d82f4ede59f6b6e7c128d5cb60b8f7d0f07808776b2a1b7656fa8acdf1b8c0d18b4b0a33479aeeebb57355b07ea2e9b6970f84bc4e0 SHA512 a80ea576a60c21f67f43a556ebead8caffcfd18fb9e777693375f591c5e842bfefff86d0d15252057b7ec1ef5cc54b66019d023880a30c88bc8bce012c9b063d
+DIST boto3-1.17.68.tar.gz 368708 BLAKE2B 4ed78bae6e8c9ee6e8f1a5a4009f89b1c5efac1ddfa8189a6ec76f1ba47b8113dd479ed935e1d6f4631fcd1e40659398a5189bab77b15e1efe5acf706871b90f SHA512 c8a4a78da518530b3e47c1f3e37f51a61070f9b626b29ee4b1a990bfb2dfce49332add6674a0ec8b156c50e922736a500f2b265cf9ba286000aca55a272a7257
diff --git a/dev-python/boto3/boto3-1.17.68.ebuild b/dev-python/boto3/boto3-1.17.68.ebuild
new file mode 100644
index 000000000000..74b9170a9119
--- /dev/null
+++ b/dev-python/boto3/boto3-1.17.68.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}