summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-02 10:12:33 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-02 10:27:00 +0200
commitc57be247b600a3144a15166b839bbc247cbb34e7 (patch)
tree4d9c021a1a17ef58af3b46a8cc0240fd7ad7fe5e
parentdev-python/pypiserver: Bump to 1.5.0 (diff)
downloadgentoo-c57be247b600a3144a15166b839bbc247cbb34e7.tar.gz
gentoo-c57be247b600a3144a15166b839bbc247cbb34e7.tar.bz2
gentoo-c57be247b600a3144a15166b839bbc247cbb34e7.zip
dev-python/apispec: Bump to 5.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/apispec/Manifest1
-rw-r--r--dev-python/apispec/apispec-5.2.1.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/apispec/Manifest b/dev-python/apispec/Manifest
index baf66d9cdca4..3ab0190a94f3 100644
--- a/dev-python/apispec/Manifest
+++ b/dev-python/apispec/Manifest
@@ -1,2 +1,3 @@
DIST apispec-5.1.1.gh.tar.gz 70296 BLAKE2B 339706890d23c796ea73c23735c5655694315a8a8017eba8f69574ed4e85ddf9a65c3a26482a78f08a118afd19e3c9bbcc9d264bb770941d7affbf7cf85eb925 SHA512 4e0e2959699c735c5242aa1a954392d97ea4809aafbd8d091f608baf7397a31964852588c474acb84e8755a62849837d741eb1e5fdf1cd5304f46c852e346d03
DIST apispec-5.2.0.gh.tar.gz 71284 BLAKE2B 554539790c58f88f475a7c638130ccdf24bcf80e024bc640919226b0a1408af97c3403ff294f47fb2cb478a26285bc6aacb021f6275eb211dc86fd31780f573a SHA512 6f36dcce8b503847a981c87ed1139b89bbb9be9e22db67402cd7e74be8a5ce58714329b33c8489b63f5aa56fe92d65fb5aea332c9bd2e8f140dfc92165432005
+DIST apispec-5.2.1.gh.tar.gz 71348 BLAKE2B c908fb3741e72d0e8a3dfd70c186255cb5862f7c51c32c5c54ea3cba38a7ce9e02143e029a505f30f284f7b5490946897fead535a9a8743549806aacd1c7791d SHA512 020d377e4dd9e2e3514cf48450bee9a5b957cb0d419f7fa4da35691b68cd108673b133d4ad07b908ca377b1418d087979eea409382ca743d350aec95b796f00f
diff --git a/dev-python/apispec/apispec-5.2.1.ebuild b/dev-python/apispec/apispec-5.2.1.ebuild
new file mode 100644
index 000000000000..e56c46d972d1
--- /dev/null
+++ b/dev-python/apispec/apispec-5.2.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pluggable API specification generator"
+HOMEPAGE="
+ https://github.com/marshmallow-code/apispec/
+ https://pypi.org/project/apispec/
+"
+SRC_URI="
+ https://github.com/marshmallow-code/apispec/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/bottle[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/marshmallow-3.13.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx-issues \
+ dev-python/sphinx_rtd_theme
+
+EPYTEST_DESELECT=(
+ # requires unpackaged prance
+ tests/test_ext_marshmallow_openapi.py::test_openapi_tools_validate_v2
+ tests/test_ext_marshmallow_openapi.py::test_openapi_tools_validate_v3
+)