summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2022-08-24 10:06:28 -0700
committerPatrick McLean <chutzpah@gentoo.org>2022-08-24 10:06:28 -0700
commitc588d0c55a2facb7b98331abf3ccb2439cc34286 (patch)
tree2faf2d3640ff6911fe7764c4f23c8f8669d87cd4
parentnet-dns/pdns-recursor: Cleanup (diff)
downloadgentoo-c588d0c5.tar.gz
gentoo-c588d0c5.tar.bz2
gentoo-c588d0c5.zip
sys-cluster/ceph: Fix CI bugs 866159, 866161, 866163, 866167
Closes: https://bugs.gentoo.org/866159 Closes: https://bugs.gentoo.org/866161 Closes: https://bugs.gentoo.org/866163 Closes: https://bugs.gentoo.org/866167 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--sys-cluster/ceph/ceph-17.2.3-r3.ebuild (renamed from sys-cluster/ceph/ceph-17.2.3-r2.ebuild)9
-rw-r--r--sys-cluster/ceph/files/ceph-17.2.3-flags.patch19
2 files changed, 28 insertions, 0 deletions
diff --git a/sys-cluster/ceph/ceph-17.2.3-r2.ebuild b/sys-cluster/ceph/ceph-17.2.3-r3.ebuild
index c31770f38434..a604240f1560 100644
--- a/sys-cluster/ceph/ceph-17.2.3-r2.ebuild
+++ b/sys-cluster/ceph/ceph-17.2.3-r3.ebuild
@@ -219,6 +219,7 @@ PATCHES=(
"${FILESDIR}/ceph-17.2.3-gcc12.patch"
"${FILESDIR}/ceph-17.2.0-gcc12-dout.patch"
"${FILESDIR}/ceph-17.2.0-gcc12-header.patch"
+ "${FILESDIR}/ceph-17.2.3-flags.patch"
)
check-reqs_export_vars() {
@@ -330,6 +331,9 @@ ceph_src_configure() {
else
mycmakeargs+=(
-DWITH_RADOSGW_SELECT_PARQUET:BOOL=OFF
+ -DWITH_JAEGER:BOOL=OFF
+ # don't want to warn about unused CLI when reconfiguring for python
+ -DCMAKE_WARN_UNUSED_CLI:BOOL=OFF
)
fi
@@ -396,6 +400,7 @@ src_install() {
python_setup
cmake_src_install
+ python_optimize
find "${ED}" -name '*.la' -type f -delete || die
@@ -460,3 +465,7 @@ pkg_postinst() {
tmpfiles_process ${PN}.conf
udev_reload
}
+
+pkg_postrm() {
+ udev_reload
+}
diff --git a/sys-cluster/ceph/files/ceph-17.2.3-flags.patch b/sys-cluster/ceph/files/ceph-17.2.3-flags.patch
new file mode 100644
index 000000000000..236ff5441831
--- /dev/null
+++ b/sys-cluster/ceph/files/ceph-17.2.3-flags.patch
@@ -0,0 +1,19 @@
+diff --git a/cmake/modules/Distutils.cmake b/cmake/modules/Distutils.cmake
+index 1916363382f..ae460d84542 100644
+--- a/cmake/modules/Distutils.cmake
++++ b/cmake/modules/Distutils.cmake
+@@ -94,12 +94,12 @@ function(distutils_add_cython_module target name src)
+ COMMAND
+ env
+ CC="${PY_CC}"
+- CFLAGS="${PY_CFLAGS}"
++ CFLAGS="${PY_CFLAGS}"\ ${CMAKE_C_FLAGS}
+ CPPFLAGS="${PY_CPPFLAGS}"
+ CXX="${PY_CXX}"
+ LDSHARED="${PY_LDSHARED}"
+ OPT=\"-DNDEBUG -g -fwrapv -w\"
+- LDFLAGS=-L${CMAKE_LIBRARY_OUTPUT_DIRECTORY}
++ LDFLAGS=-L${CMAKE_LIBRARY_OUTPUT_DIRECTORY}\ ${CMAKE_LINKER_FLAGS}\ ${CMAKE_SHARED_LINKER_FLAGS}
+ CYTHON_BUILD_DIR=${CMAKE_CURRENT_BINARY_DIR}
+ CEPH_LIBDIR=${CMAKE_LIBRARY_OUTPUT_DIRECTORY}
+ ${Python3_EXECUTABLE} ${setup_py}