summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-11 05:42:35 +0100
committerSam James <sam@gentoo.org>2023-04-13 04:00:54 +0100
commitc5913bdd45d47b4894a1c76d78bcc60748ccf913 (patch)
treec62c3018bc807d90f67a1212d476be39c2dfc345
parentdev-ruby/domain_name: drop dev-ruby/unf dependency, enable ruby32 (diff)
downloadgentoo-c5913bdd45d47b4894a1c76d78bcc60748ccf913.tar.gz
gentoo-c5913bdd45d47b4894a1c76d78bcc60748ccf913.tar.bz2
gentoo-c5913bdd45d47b4894a1c76d78bcc60748ccf913.zip
dev-ruby/http-cookie: enable ruby32
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-ruby/http-cookie/http-cookie-1.0.5-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/http-cookie/http-cookie-1.0.5-r1.ebuild b/dev-ruby/http-cookie/http-cookie-1.0.5-r1.ebuild
new file mode 100644
index 000000000000..6e8ed8373fb5
--- /dev/null
+++ b/dev-ruby/http-cookie/http-cookie-1.0.5-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A ruby library to handle HTTP cookies"
+HOMEPAGE="https://github.com/sparklemotion/http-cookie"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE=""
+
+# See https://github.com/sparklemotion/http-cookie/issues/16 for dropping domain_name
+ruby_add_rdepend ">=dev-ruby/domain_name-0.5:0"
+
+all_ruby_prepare() {
+ sed -i -e "/simplecov/d" -e "/bundler/d" Rakefile || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib test/test_http_cookie.rb || die
+ ${RUBY} -Ilib test/test_http_cookie_jar.rb || die
+}