summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-03-02 10:00:58 +0100
committerJeroen Roovers <jer@gentoo.org>2020-03-10 09:22:27 +0100
commitc59c3935ff8769fb9e109bba5471fca5e4fac9e5 (patch)
tree72557eb7e3425c4e961ce0d086146b28c9c6a584
parentnet-analyzer/cacti: Version 1.2.10 (diff)
downloadgentoo-c59c3935ff8769fb9e109bba5471fca5e4fac9e5.tar.gz
gentoo-c59c3935ff8769fb9e109bba5471fca5e4fac9e5.tar.bz2
gentoo-c59c3935ff8769fb9e109bba5471fca5e4fac9e5.zip
net-analyzer/cacti-spine: Version 1.2.10
Package-Manager: Portage-2.3.90, Repoman-2.3.20 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
-rw-r--r--net-analyzer/cacti-spine/Manifest1
-rw-r--r--net-analyzer/cacti-spine/cacti-spine-1.2.10.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/net-analyzer/cacti-spine/Manifest b/net-analyzer/cacti-spine/Manifest
index 936e540866a9..5a6dd9407f6c 100644
--- a/net-analyzer/cacti-spine/Manifest
+++ b/net-analyzer/cacti-spine/Manifest
@@ -1 +1,2 @@
+DIST cacti-spine-1.2.10.tar.gz 106625 BLAKE2B 8038fb4352b71d5885b07d2ca5af76c38369d2a904f1b669da31a82b0d25bcebf63c5facdb268ee5f4c6bc4bf4772f120bbf85101831cea9ac7d469ed93b27f9 SHA512 56e796a613037b49e54fa07654f337ac7522cb9ead81673f3e1dcd61b29d152b997a2f46a7c2b28409944ffd3ba3afa70d4867f2d0ff7f58525372bae41f1048
DIST cacti-spine-1.2.9.tar.gz 106572 BLAKE2B 803d16b6708e4cc5fc5ea9a5cb49bfd535fea421a873ce9baf74e1de75597a5a4941a909219d729e291ff3201c0f9c2a8304381144d935778ef331779395c688 SHA512 668b25cb89fad331ae4bc726b797bbeade74c90500af348748a995be0de2f699264cd24e98ea709214453328058e1dba6399dca2074bb6ce71e0d4b434b9dee4
diff --git a/net-analyzer/cacti-spine/cacti-spine-1.2.10.ebuild b/net-analyzer/cacti-spine/cacti-spine-1.2.10.ebuild
new file mode 100644
index 000000000000..a5c1da23c064
--- /dev/null
+++ b/net-analyzer/cacti-spine/cacti-spine-1.2.10.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+MY_P=${PN}-${PV/_p/-}
+
+DESCRIPTION="Spine is a fast poller for Cacti (formerly known as Cactid)"
+HOMEPAGE="https://cacti.net/spine_info.php"
+SRC_URI="https://www.cacti.net/downloads/spine/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="libressl"
+
+CDEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ net-analyzer/net-snmp:=
+ dev-db/mysql-connector-c:0=
+"
+DEPEND="
+ ${CDEPEND}
+ sys-apps/help2man
+"
+RDEPEND="
+ ${CDEPEND}
+ >net-analyzer/cacti-0.8.8
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.8.8g-net-snmp.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_install() {
+ dosbin spine
+
+ insinto /etc/
+ insopts -m0640 -o root
+ newins spine.conf{.dist,}
+
+ doman spine.1
+ dodoc CHANGELOG
+}