summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-17 09:23:37 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-17 10:21:40 +0100
commitc5b63245908db55cc41bcb87fb34b9f4e7bee6a9 (patch)
treec05ae2cbf76bab32e35eb572b2d941b06bc129e3
parentRevert "app-crypt/mit-krb5: security cleanup" (diff)
downloadgentoo-c5b63245908db55cc41bcb87fb34b9f4e7bee6a9.tar.gz
gentoo-c5b63245908db55cc41bcb87fb34b9f4e7bee6a9.tar.bz2
gentoo-c5b63245908db55cc41bcb87fb34b9f4e7bee6a9.zip
dev-python/botocore: Bump to 1.19.19
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.19.19.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 5643e5b9093b..433df0917804 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -10,5 +10,6 @@ DIST botocore-1.19.15.tar.gz 6996595 BLAKE2B 562bb257f481a5668d25c99a4a6d27bff6f
DIST botocore-1.19.16.tar.gz 7009239 BLAKE2B d582538f25c500297ab8a5ce3f054a5ba2f94d0d5f37d0aeee934943854bb5fc429e33040b56d1e06cfd93a51bd917c96dac9432c5b84d59513b47af52285ac1 SHA512 d36b580e0ad56143b9b36679d17910fcdb49ec132143441d6a078797f79bec1fd6f06b2afb8542e16e844fb892c2902aeab1cfcf66a8ddb9ecbcc92be4ced29d
DIST botocore-1.19.17.tar.gz 7021338 BLAKE2B f03ba2d6db87bf5ce11a778bdc0f9a3adba54b4b245a106cbf20aec6ac2ebc4a09d57e6e93518c142552782cba380d5c195a4efc68a49be5709d7c014b58172d SHA512 2ed07ed3e4f6b43b24e1766cc0c74950bdce3e88d3ff9c10798bd99361c6314b45bed3c6fd74467b5c05470f9d6baf122c241dfb5a5a4aaab6c39fd9aa689b96
DIST botocore-1.19.18.tar.gz 7024457 BLAKE2B 98adb675219f13b38b0a219eaa0437a2f81623f57433907d6615e49f36c580eabf3352f9f6a53b7a261262d8f164f2a019888cc31947c16ef69cc54536067f0e SHA512 bf247c773415cc2aa672c0d5ee2258ec2d5c77909d72c24f2190f962f7d3546427c2008f22cdb13534cb1bd1e3c249cbf268629316ddee50bde22643d720c330
+DIST botocore-1.19.19.tar.gz 7027786 BLAKE2B 237c3973439a7ff3b6a1be9bd2993cbcb8e7a21922ed71b23361a12eca706f2bbee05ad2a36d89744146e7555e1cbf08f311f09362cddc20c9f078c187592dba SHA512 554cc8ebf865739aa1289aeaaf8abeb705603d6e727682298e573025ceb4a9f60263177eb96bb6381d603f5341310296f374e8643c37c1325a281d0f8efd42cb
DIST botocore-1.19.8.tar.gz 6970481 BLAKE2B 52d3f8ee7dc38feddb3f7799959624b4baf4b75ebcf3ad8257c25ad13b8a8c3cf526ee187681b6d8f5f6ee874071a02c59bd106cb4b4e23ad9cf13b9aa74deef SHA512 845dfec33f63deee44bfffe81801995bfcc2014880c2d520b927421219279107b0fe44dc84425c0a55ddec73d5ad8aeb34f2b84178e1365d137240a2e94370c7
DIST botocore-1.19.9.tar.gz 6972834 BLAKE2B 3407c056c7995cc1ccb1b5b4c5b3a6254e38672b52e7889a7a022520283416e4dfcabd05c8ca0ed78e4624c7a20c9f43bfde87a76d7a72660b4c95256e4f9ca4 SHA512 8433f22ae7652e524a82da8d2ccda48da9eef44788333898b7526335d57a7757b80754f0d5c6a2c84ec3bde2ec9fc7da5cf872cbda7286f620b4f4878fe9a583
diff --git a/dev-python/botocore/botocore-1.19.19.ebuild b/dev-python/botocore/botocore-1.19.19.ebuild
new file mode 100644
index 000000000000..ca40b64d111f
--- /dev/null
+++ b/dev-python/botocore/botocore-1.19.19.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}