summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2018-02-07 11:35:09 -0800
committerZac Medico <zmedico@gentoo.org>2018-02-07 11:40:43 -0800
commitc5bd4ddefd1b1f6e8b9f69da68e6aef5249bc5a5 (patch)
tree4cb8f7e41404cb654e4705202c929c234a4bc041
parentapp-admin/conky: Version bump. (diff)
downloadgentoo-c5bd4dde.tar.gz
gentoo-c5bd4dde.tar.bz2
gentoo-c5bd4dde.zip
sys-apps/portage: disable rsync-verify for stage1 build
Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--sys-apps/portage/portage-2.3.24.ebuild12
-rw-r--r--sys-apps/portage/portage-9999.ebuild7
2 files changed, 12 insertions, 7 deletions
diff --git a/sys-apps/portage/portage-2.3.24.ebuild b/sys-apps/portage/portage-2.3.24.ebuild
index 9c6f5d9387dc..f0ad350864b1 100644
--- a/sys-apps/portage/portage-2.3.24.ebuild
+++ b/sys-apps/portage/portage-2.3.24.ebuild
@@ -44,17 +44,17 @@ RDEPEND="
>=app-admin/eselect-1.2
$(python_gen_cond_dep 'dev-python/pyblake2[${PYTHON_USEDEP}]' \
python{2_7,3_4,3_5} pypy)
+ rsync-verify? (
+ >=app-portage/gemato-10
+ app-crypt/gentoo-keys
+ app-crypt/gnupg[ssl(-)]
+ )
)
elibc_FreeBSD? ( sys-freebsd/freebsd-bin )
elibc_glibc? ( >=sys-apps/sandbox-2.2 )
elibc_musl? ( >=sys-apps/sandbox-2.2 )
elibc_uclibc? ( >=sys-apps/sandbox-2.2 )
>=app-misc/pax-utils-0.1.17
- rsync-verify? (
- >=app-portage/gemato-10
- app-crypt/gentoo-keys
- app-crypt/gnupg[ssl(-)]
- )
selinux? ( >=sys-libs/libselinux-2.0.94[python,${PYTHON_USEDEP}] )
xattr? ( kernel_linux? (
>=sys-apps/install-xattr-0.3
@@ -123,7 +123,7 @@ python_prepare_all() {
|| die "failed to append to make.globals"
fi
- if ! use rsync-verify; then
+ if use build || ! use rsync-verify; then
sed -e '/^sync-rsync-verify-metamanifest/s|yes|no|' \
-i cnf/repos.conf || die "sed failed"
fi
diff --git a/sys-apps/portage/portage-9999.ebuild b/sys-apps/portage/portage-9999.ebuild
index e91f5535212f..2df6101a5f93 100644
--- a/sys-apps/portage/portage-9999.ebuild
+++ b/sys-apps/portage/portage-9999.ebuild
@@ -44,6 +44,11 @@ RDEPEND="
>=app-admin/eselect-1.2
$(python_gen_cond_dep 'dev-python/pyblake2[${PYTHON_USEDEP}]' \
python{2_7,3_4,3_5} pypy)
+ rsync-verify? (
+ >=app-portage/gemato-10
+ app-crypt/gentoo-keys
+ app-crypt/gnupg[ssl(-)]
+ )
)
elibc_FreeBSD? ( sys-freebsd/freebsd-bin )
elibc_glibc? ( >=sys-apps/sandbox-2.2 )
@@ -122,7 +127,7 @@ python_prepare_all() {
|| die "failed to append to make.globals"
fi
- if ! use rsync-verify; then
+ if use build || ! use rsync-verify; then
sed -e '/^sync-rsync-verify-metamanifest/s|yes|no|' \
-i cnf/repos.conf || die "sed failed"
fi