summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2018-06-03 16:28:49 +1200
committerKent Fredric <kentnl@gentoo.org>2018-06-03 16:29:08 +1200
commitc5c20fc3b87272997d1e246261ee84abd14e298f (patch)
treeb68a312f4de53b7068687d6d0786d6eb84cde032
parentvirtual/perl-Storable: copy stable s390 and sh bits from dev-lang/perl (diff)
downloadgentoo-c5c20fc3.tar.gz
gentoo-c5c20fc3.tar.bz2
gentoo-c5c20fc3.zip
dev-perl/DBD-SQLite: Bump to version 1.580.0 re bug #656546
Upstream: - Now an error to fetch attributes from a statement handle whose database handle is inactive. Closes: https://bugs.gentoo.org/656546 Package-Manager: Portage-2.3.29, Repoman-2.3.9
-rw-r--r--dev-perl/DBD-SQLite/DBD-SQLite-1.580.0.ebuild47
-rw-r--r--dev-perl/DBD-SQLite/Manifest1
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-perl/DBD-SQLite/DBD-SQLite-1.580.0.ebuild b/dev-perl/DBD-SQLite/DBD-SQLite-1.580.0.ebuild
new file mode 100644
index 000000000000..8e84fa9db15b
--- /dev/null
+++ b/dev-perl/DBD-SQLite/DBD-SQLite-1.580.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=ISHIGAKI
+DIST_VERSION=1.58
+inherit perl-module
+
+DESCRIPTION="Self Contained RDBMS in a DBI Driver"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="test system-sqlite"
+
+# Please read https://wiki.gentoo.org/wiki/Project:Perl/maint-notes/dev-perl/DBD-SQLite
+# when bumping versions re: system-sqlite interop
+RDEPEND="
+ system-sqlite? (
+ >=dev-db/sqlite-3.21.0[extensions(+)]
+ )
+ >=dev-perl/DBI-1.570.0
+ !<dev-perl/DBD-SQLite-1
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.480.0
+ test? (
+ >=virtual/perl-File-Spec-0.820.0
+ >=virtual/perl-Test-Simple-0.420.0
+ )
+"
+
+src_prepare() {
+ perl-module_src_prepare
+ if use system-sqlite; then
+ einfo "Removing bundled SQLite"
+ # Flip Makefile into system mode.
+ sed -i 's/^if ( 0 )/if ( 1 )/' "${S}"/Makefile.PL || die
+ # remove bundled sqlite (rt.cpan#61361)
+ for i in sqlite3{.c,.h,ext.h} ; do
+ rm ${i} || die
+ sed -i -e "/^${i}\$/d" MANIFEST || die
+ done
+ myconf="SQLITE_LOCATION=${EPREFIX}/usr"
+ fi
+}
diff --git a/dev-perl/DBD-SQLite/Manifest b/dev-perl/DBD-SQLite/Manifest
index 5779d990c4df..e75f4fd7d322 100644
--- a/dev-perl/DBD-SQLite/Manifest
+++ b/dev-perl/DBD-SQLite/Manifest
@@ -1 +1,2 @@
DIST DBD-SQLite-1.56.tar.gz 2248699 BLAKE2B d6af8efed8149ff2ec5c68cc071355805f4a24e234e015c180d5326a4def4eab33352d168e9e41c06b2de28a0137f0d39a864749bfa972d28f8ec9221379bdc1 SHA512 1c9be3557691f76a9e543fe4bd6656a6b82f53fba4bc05261a55affa0a38b4eaa1cf876da975234c9c09985ba25b21f6f7a735f1cc47104169edf7fdd3a2e314
+DIST DBD-SQLite-1.58.tar.gz 2248800 BLAKE2B 54cb94d0c64389984290361104e723be4cc9c7352e2f1c80838efa15d8f3d9d671705117422a1076203821b24ef63e06bf95244a0bdd7b710394e655041af18e SHA512 080d1e304fb0d43926ce0345df3367132c317ba113bdc11952c0a159bc68d988a024828a28e66be267f82e07731dee225723854fb80914ba7c476b27dbdeb212