summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-11-24 10:51:01 +0000
committerSam James <sam@gentoo.org>2020-11-24 10:53:06 +0000
commitc5d7ebe958e82785ecf2ed5428e2a03dac119e29 (patch)
tree189b3e95b9d2c0048afa4987168dccc826ccec7f
parentapp-crypt/trousers: add patch for LibreSSL (diff)
downloadgentoo-c5d7ebe958e82785ecf2ed5428e2a03dac119e29.tar.gz
gentoo-c5d7ebe958e82785ecf2ed5428e2a03dac119e29.tar.bz2
gentoo-c5d7ebe958e82785ecf2ed5428e2a03dac119e29.zip
app-text/qpdf: security bump to 10.0.4
Bug: https://bugs.gentoo.org/756022 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-text/qpdf/Manifest1
-rw-r--r--app-text/qpdf/qpdf-10.0.4.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/app-text/qpdf/Manifest b/app-text/qpdf/Manifest
index 6a3b8056d93e..c8616542fbf8 100644
--- a/app-text/qpdf/Manifest
+++ b/app-text/qpdf/Manifest
@@ -1,3 +1,4 @@
DIST qpdf-10.0.1.tar.gz 18399985 BLAKE2B 5e113790e7c2b48987c18aa7f562ff18f0efb544c48be8c36ba201ba1420168a7f32ebfe2e5754e8af679557df29093e0fd550c991b5201e4246be827952b3d3 SHA512 b73c0839b08905052d90ed78645cc9fb4fda4a0fa803db7b46f3d77a2c2f7e8cec52173834b1e1f008f3a3475a7d913362d22e1ebece11187a90c9035b81de94
+DIST qpdf-10.0.4.tar.gz 18465085 BLAKE2B 3b9edc38069d58d43d26b131da755b7921b7add905ed652e3abb48d9b2e140d0c3b38f0250dbd3dca1c4b3dadf76c636606c6fa802b1ebe2dda77444badd828e SHA512 0a8c243928a3273d78b4a898e17a619f1565ec5e9b6f637800a2937749fb8006d0438fee2e623d2f8dc715bfb478ee818e86e9da7c7e0fcf14af496464b79a07
DIST qpdf-9.0.2.tar.gz 18168977 BLAKE2B 46b397f0e6a97804c5e8dcbfc9fd2278960d5afd459430c1790bb8f9080062cf661cf186ab386721ed7560dbd4abbea43e4d31914c0636502c5c11096c250fe2 SHA512 275ca81603d53601e4389cb34eaebea1c5d52b310ef28f3375fbeee255a28edf9375f03f31649f580dbc3df73b851a2c8498feb3dd7b30067955571b05c9e69c
DIST qpdf-9.1.1.tar.gz 18312457 BLAKE2B 0bbfaa782e46a911b20440bcf122d2745dde62de16423307cb02f7f3cd9a4976c79c7f6371322f793abfd8eaf9d5cc4f49b6854e58039595b5a488a2fec98d88 SHA512 008a11fef663a57ca173631f2053988023babea6c333cfe01db0ef955c8cd36d387ed9f2039f55bd5f9ca94c7a8e400461a09a15c5f89e03bc0817fdd0d3d585
diff --git a/app-text/qpdf/qpdf-10.0.4.ebuild b/app-text/qpdf/qpdf-10.0.4.ebuild
new file mode 100644
index 000000000000..d49539fd3d48
--- /dev/null
+++ b/app-text/qpdf/qpdf-10.0.4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Command-line tool for structural, content-preserving transformation of PDF files"
+HOMEPAGE="http://qpdf.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qpdf/${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 Artistic-2 )"
+# subslot = libqpdf soname version
+SLOT="0/28"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~m68k-mint ~sparc-solaris"
+IUSE="doc examples libressl ssl test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ net-libs/gnutls:0=
+ sys-libs/zlib
+ virtual/jpeg:0=
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+"
+DEPEND="${RDEPEND}
+ test? (
+ app-text/ghostscript-gpl[tiff(+)]
+ media-libs/tiff
+ sys-apps/diffutils
+ )
+"
+
+DOCS=( ChangeLog README.md TODO )
+
+src_configure() {
+ local myeconfargs=(
+ --disable-implicit-crypto
+ --enable-crypto-gnutls
+ --enable-crypto-native
+ --with-default-crypto=gnutls
+ --disable-static
+ $(use_enable ssl crypto-openssl)
+ $(use_enable test test-compare-images)
+ )
+ CONFIG_SHELL="${BROOT}/bin/bash" econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ if use examples ; then
+ dobin examples/build/.libs/*
+ fi
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}