summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-30 13:43:29 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-30 14:09:27 +0100
commitc5d94057f4882986ecba01586d8b83191583550b (patch)
treec932f2b9b2ab38e80de6e1ec4afbe63c81b06924
parentdev-python/rcssmin: Switch to PEP 517 build (diff)
downloadgentoo-c5d94057f4882986ecba01586d8b83191583550b.tar.gz
gentoo-c5d94057f4882986ecba01586d8b83191583550b.tar.bz2
gentoo-c5d94057f4882986ecba01586d8b83191583550b.zip
dev-python/rtimulib: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/rtimulib/rtimulib-7.2.1-r2.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/rtimulib/rtimulib-7.2.1-r2.ebuild b/dev-python/rtimulib/rtimulib-7.2.1-r2.ebuild
new file mode 100644
index 000000000000..630e51b241c8
--- /dev/null
+++ b/dev-python/rtimulib/rtimulib-7.2.1-r2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_PN="RTIMULib"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python Binding for RTIMULib, a versatile IMU library"
+HOMEPAGE="https://github.com/RPi-Distro/RTIMULib"
+SRC_URI="https://github.com/RPi-Distro/${MY_PN}/archive/V${PV}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}/Linux/python"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"