summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-08-28 12:03:53 -0700
committerMatt Turner <mattst88@gentoo.org>2021-08-28 14:14:23 -0700
commitc5eb2e04671af429955094a56cd4145088f29894 (patch)
tree6553017b7d6771bed51cc24bb2e0623066d9674f
parentdev-python/setuptools_scm_git_archive: force setuptools_scm < 6.0.1 (diff)
downloadgentoo-c5eb2e04.tar.gz
gentoo-c5eb2e04.tar.bz2
gentoo-c5eb2e04.zip
app-text/iso-codes: Version bump to 4.7.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--app-text/iso-codes/Manifest1
-rw-r--r--app-text/iso-codes/iso-codes-4.7.0.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/app-text/iso-codes/Manifest b/app-text/iso-codes/Manifest
index 5989f5c08519..3ee204c953f5 100644
--- a/app-text/iso-codes/Manifest
+++ b/app-text/iso-codes/Manifest
@@ -1 +1,2 @@
DIST iso-codes-4.6.0.tar.gz 14089611 BLAKE2B 0e85ca49dd40ca053af4b06aca440e55c2b9bb2061fcdceaa25b31ac7fd7942a590756db90c10db64e5e1ffcedbce5a552e60a6d495bb9d60621bc7b862e630b SHA512 fcee802a3f92ef035371ff45fa9d8acbf1e2f490e38d84d2e27d2226d250ad02d088156d0889c0fc0fc09f30c4541b30dc7eb65ca4f40c3764599c1b2143013f
+DIST iso-codes-4.7.0.tar.gz 14122654 BLAKE2B 5dfcf4a0b39ff7b696f157a3938b7c1d35015c346ba4b046dda6b6b5bdcb02e561161afecfd2909fdbfbff6378cd4940335543d0ca7313bb9e80e490ad901abb SHA512 77ceb2ba9f3290f9409efdb50112beda2872ed163a86912b46480407f1135c0263cb70bf84bd2635b304d1af65e5b60f97a20b305219ead9ac98423b5abb255d
diff --git a/app-text/iso-codes/iso-codes-4.7.0.ebuild b/app-text/iso-codes/iso-codes-4.7.0.ebuild
new file mode 100644
index 000000000000..b89d5b65020f
--- /dev/null
+++ b/app-text/iso-codes/iso-codes-4.7.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+PLOCALES="ab ace ach af ak am an ar as ast ay az ba bar be bg bi bn bn_BD bn_IN br bs byn ca ce ch chr ckb crh cs csb cv cy da de dv dz ee el en eo es et eu fa ff fi fil fo fr frp fur fy ga gez gl gn gu gv ha haw he hi hr ht hu hy ia id io is it iu ja jam ka kab ki kk kl km kmr kn ko kok kv kw ky lo lt lv mai mhr mi mk ml mn mo mr ms mt my na nah nb nb_NO ne nl nn nso nv oc or pa pap pi pl ps pt pt_BR ro ru rw sc sd si sk sl so son sq sr sr@latin sv sw ta te tg th ti tig tk tl tr tt tt@iqtelif tzm ug uk ur uz ve vi wa wal wo xh yo zh_CN zh_HK zh_Hant zh_TW zu"
+
+inherit python-any-r1
+
+DESCRIPTION="ISO language, territory, currency, script codes and their translations"
+HOMEPAGE="https://salsa.debian.org/iso-codes-team/iso-codes"
+SRC_URI="https://salsa.debian.org/${PN}-team/${PN}/-/archive/${P}/${PN}-${P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+
+BDEPEND="${PYTHON_DEPS}
+ sys-devel/gettext
+"
+S="${WORKDIR}/${PN}-${P}"
+
+# This ebuild does not install any binaries.
+RESTRICT="binchecks strip"
+
+DOCS=( ChangeLog.md README.md )
+
+# plocale_find_changes doesn't support multiple directories,
+# so need to do the update scan ourselves.
+check_existing_locales() {
+ local std loc all_locales=()
+
+ ebegin "Looking for new locales"
+ for std in "${all_stds[@]}"; do
+ pushd "${std}" >/dev/null || die
+ for loc in *.po; do
+ all_locales+=( "${loc%.po}" )
+ done
+ popd >/dev/null
+ done
+
+ all_locales=$(echo $(printf '%s\n' "${all_locales[@]}" | LC_COLLATE=C sort -u))
+ if [[ ${PLOCALES} != "${all_locales}" ]]; then
+ eend 1
+ eerror "There are changes in locales! This ebuild should be updated to:"
+ eerror "PLOCALES=\"${all_locales}\""
+ die "Update PLOCALES in the ebuild"
+ else
+ eend 0
+ fi
+}
+
+src_prepare() {
+ default
+
+ local std loc mylinguas
+ local all_stds=( iso_15924 iso_3166-{1,2,3} iso_4217 iso_639-{2,3,5} )
+
+ check_existing_locales
+
+ # Modify the Makefiles so they only install requested locales.
+ for std in "${all_stds[@]}"; do
+ einfo "Preparing ${std} ..."
+ pushd "${std}" >/dev/null || die
+ mylinguas=()
+ for loc in *.po; do
+ if has ${loc%.po} ${LINGUAS-${loc%.po}}; then
+ mylinguas+=( "${loc}" )
+ fi
+ done
+
+ sed \
+ -e "/^pofiles =/s:=.*:= ${mylinguas[*]}:" \
+ -e "/^mofiles =/s:=.*:= ${mylinguas[*]/%.po/.mo}:" \
+ -i Makefile.am Makefile.in || die "sed in ${std} folder failed"
+ popd >/dev/null
+ done
+}