summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-09 07:08:29 +0000
committerSam James <sam@gentoo.org>2022-01-09 07:09:20 +0000
commitc5edea7c599890bb14b29b829482ceb98f892eb7 (patch)
tree9cbaab4352b9f6e9de32e23fb5f5ece669e81a9f
parentnet-misc/socat: add 1.7.4.3 (diff)
downloadgentoo-c5edea7c.tar.gz
gentoo-c5edea7c.tar.bz2
gentoo-c5edea7c.zip
dev-embedded/platformio: add 5.2.4
Closes: https://bugs.gentoo.org/830746 Closes: https://bugs.gentoo.org/830802 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-embedded/platformio/Manifest1
-rw-r--r--dev-embedded/platformio/platformio-5.2.4.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-embedded/platformio/Manifest b/dev-embedded/platformio/Manifest
index ac9c341b2438..6494b00254dc 100644
--- a/dev-embedded/platformio/Manifest
+++ b/dev-embedded/platformio/Manifest
@@ -1,2 +1,3 @@
DIST platformio-5.1.1.tar.gz 215305 BLAKE2B a7854138dec1b5b58c4f715dde98a273ed08c0da7fb305f89490944c210737c7c500731b21a5a9cb2bf3be3925f1666ef1084992b99df46d3ee83b449baaaa35 SHA512 f74ae3cb46065379b90c7ec3574d6ff0076085cd891bf41be2f38b6c6b59f87f4d013c1da6e4825f7d831ed17136e433385ab07c3f16b31342d5415192f87eff
DIST platformio-5.2.3.tar.gz 252483 BLAKE2B f60b83f6647333d42b5d864ea468c8104dcd5a83085a6d52f456a21792d9c94641a60f698c2a606ddd7d7b3a588723831f35ac0d3027cb0ff8b8226dabe3b62c SHA512 c11f58a984b15a3363cd29bf9a0234c1ffc772cc153310d420037416bb8834cb2b74899ccb465d69db862cc088cfcb17dcbc7d919f690b6e836dec982d5b136b
+DIST platformio-5.2.4.tar.gz 254337 BLAKE2B e29b69a514b5f3bc6faefb15dd4e3195152d74b763961c35c33cd9e44bcd430920dc2f4d553244c2ac1bb83d745c006c67d2d52973fa07562c8b98d8e74a2ac3 SHA512 f90c1f5d9dcada99c610003b26ccaa4e08c214757d0c26daeea3cae006a02179aea1eb0bc656751913d0b2c4161195b1afe9ab0eaab5ad594ff986f6b56728f8
diff --git a/dev-embedded/platformio/platformio-5.2.4.ebuild b/dev-embedded/platformio/platformio-5.2.4.ebuild
new file mode 100644
index 000000000000..21416a0b2fad
--- /dev/null
+++ b/dev-embedded/platformio/platformio-5.2.4.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1 udev
+
+DESCRIPTION="An open source ecosystem for IoT development"
+HOMEPAGE="https://platformio.org/"
+SRC_URI="https://github.com/platformio/platformio-core/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-core-${PV}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/aiofiles-0.8.0[${PYTHON_USEDEP}]
+ dev-python/ajsonrpc[${PYTHON_USEDEP}]
+ <dev-python/bottle-0.13[${PYTHON_USEDEP}]
+ >=dev-python/click-7.1.2[${PYTHON_USEDEP}]
+ <dev-python/click-9[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ >=dev-python/pyserial-3[${PYTHON_USEDEP}]
+ <dev-python/pyserial-4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.4[${PYTHON_USEDEP}]
+ <dev-python/requests-3[${PYTHON_USEDEP}]
+ >=dev-python/semantic_version-2.8.1[${PYTHON_USEDEP}]
+ <dev-python/semantic_version-3[${PYTHON_USEDEP}]
+ >=dev-python/tabulate-0.8.3[${PYTHON_USEDEP}]
+ <dev-python/tabulate-1[${PYTHON_USEDEP}]
+ dev-python/twisted[${PYTHON_USEDEP}]
+ >=dev-python/pyelftools-0.25[${PYTHON_USEDEP}]
+ <dev-python/pyelftools-1[${PYTHON_USEDEP}]
+ >=dev-python/marshmallow-2.20.5[${PYTHON_USEDEP}]
+ >=dev-python/starlette-0.17[${PYTHON_USEDEP}]
+ >=dev-python/uvicorn-0.16[${PYTHON_USEDEP}]
+ dev-python/wsproto[${PYTHON_USEDEP}]
+ dev-python/zeroconf[${PYTHON_USEDEP}]
+ ')
+ virtual/udev"
+DEPEND="virtual/udev"
+BDEPEND="test? ( $(python_gen_cond_dep 'dev-python/jsondiff[${PYTHON_USEDEP}]') )"
+
+# This list could be refined a bit to have individual tests which need network
+# (within EPYTEST_DESELECT) but so many need it that it doesn't seem worth it right now.
+EPYTEST_IGNORE=(
+ # Requires network access
+ tests/test_builder.py
+ tests/package/test_manager.py
+ tests/package/test_manifest.py
+ tests/commands/test_platform.py
+ tests/commands/test_test.py
+ tests/commands/test_ci.py
+ tests/commands/test_init.py
+ tests/commands/test_lib.py
+ tests/commands/test_lib_complex.py
+ tests/commands/test_boards.py
+ tests/commands/test_check.py
+ tests/test_ino2cpp.py
+ tests/test_maintenance.py
+ tests/test_misc.py
+)
+
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+ udev_dorules scripts/99-platformio-udev.rules
+}