summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2021-04-02 10:16:53 +0300
committerMikle Kolyada <zlogene@gentoo.org>2021-04-02 10:20:37 +0300
commitc61729fe85767e7f4fa54d99282f8dadd16e50df (patch)
tree5c0f30b6023bd799f5d5782169300445538c659a
parentdev-cpp/abseil-cpp: fix cmake warning (diff)
downloadgentoo-c61729fe.tar.gz
gentoo-c61729fe.tar.bz2
gentoo-c61729fe.zip
dev-libs/kpathsea: Version bump (v6.3.3_p20210325)
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
-rw-r--r--dev-libs/kpathsea/Manifest1
-rw-r--r--dev-libs/kpathsea/files/kpathsea.conf1
-rw-r--r--dev-libs/kpathsea/kpathsea-6.3.3_p20210325.ebuild106
3 files changed, 108 insertions, 0 deletions
diff --git a/dev-libs/kpathsea/Manifest b/dev-libs/kpathsea/Manifest
index 4ad13c507388..21b83650638a 100644
--- a/dev-libs/kpathsea/Manifest
+++ b/dev-libs/kpathsea/Manifest
@@ -1,4 +1,5 @@
DIST kpathsea-texmf.d-10.tar.xz 12784 BLAKE2B fcd9b46504c58da90babcbd1e5d4ea655d3cb85f4be0a7430da62758f9b11e68219adcafab9ae26756f3f9dfa97b460db3e8b8b1a27560d2f3a91e612336dc75 SHA512 f2cc6a1bbc7be463877fd57d5351fb9e7bda472f1094f93a6962e14f9d71067cdae87464b615818341728c9fbd32e67f060dc09a3590353715fbc31fe64f93ef
DIST texlive-20200406-source.tar.xz 55383320 BLAKE2B 3bc024166ebfc269389531c7cf818b062856cd2dcc27cf0a2e790f07cd941d9905c9c6a54566ea627ea1ca334d2b6da8d3e5bd1c686dc9d6f8ac15aac388c1e3 SHA512 65be52cb5e1b52f12feb62c6cf23e56c581b9dccb8d3b9ccc85c12c62b0cb67dd71de8d22d967d2cbf8403502c66bccb238523d13a0d081be104fc9f9c68b477
+DIST texlive-20210325-source.tar.xz 54837368 BLAKE2B 66bd4bdd43ff53513004b9b9b90ababa0ab5efcf183a27864a3d39cde9cf90721456bda90c49ad6014f4b12d2e6293feaf9a8b152b85a89ffaa96bf5056347df SHA512 afd6eb24efaeac7c58d43ff24162aece919079a9ae02934509f068c7a3828223c33c14d9db11ff7fea3560b08a06f352446ba7f845eefb4a56a87b96f088f213
DIST tl-kpathsea-2020.tar.xz 32324 BLAKE2B bf4365d3ae47ce5344916d6622d40c121a34e722d166c983224f356c75d1b3e10216182ee79a76cf1dc703741e5302d8b427215a72af3060bae05b698ac0c316 SHA512 53887f73784f96528081bf9ce39fdaff3c94b2af1827cc2da7abddf2821c86c45f014ddcb624b24ed6265b7de25132dd106040f736fea180c122c9026f6cd101
DIST tl-kpathsea.doc-2020.tar.xz 1066608 BLAKE2B 02f9fd2e704392c6b82af9317418f4baeead00d02a204db0e7d58ba5eb9da6047a0bfd235123964c78bed5da68e79bd0964f943331f2ceb03ff591fd4efba266 SHA512 fd9d0de2cc576ced6ad5d0ba6dd07d0f8a1e63dc473de849148b5a7890277122f7a37ea6476db20ff3b56546cd467126a881505aa60ef66a86a232e35e3f3303
diff --git a/dev-libs/kpathsea/files/kpathsea.conf b/dev-libs/kpathsea/files/kpathsea.conf
new file mode 100644
index 000000000000..f68f5d5e125c
--- /dev/null
+++ b/dev-libs/kpathsea/files/kpathsea.conf
@@ -0,0 +1 @@
+d /var/cache/fonts 1777 root root -
diff --git a/dev-libs/kpathsea/kpathsea-6.3.3_p20210325.ebuild b/dev-libs/kpathsea/kpathsea-6.3.3_p20210325.ebuild
new file mode 100644
index 000000000000..100fb4e9fb9c
--- /dev/null
+++ b/dev-libs/kpathsea/kpathsea-6.3.3_p20210325.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit texlive-common libtool prefix tmpfiles
+
+TEXMFD_VERSION="10"
+
+DESCRIPTION="Path searching library for TeX-related files"
+HOMEPAGE="http://tug.org/texlive/"
+SRC_URI="https://dev.gentoo.org/~zlogene/distfiles/texlive/texlive-${PV#*_p}-source.tar.xz
+ https://dev.gentoo.org/~zlogene/distfiles/texlive/${PN}-texmf.d-${TEXMFD_VERSION}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0/${PV%_p*}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc source static-libs"
+
+S=${WORKDIR}/texlive-${PV#*_p}-source/texk/${PN}
+
+TL_VERSION=2020
+EXTRA_TL_MODULES="kpathsea"
+EXTRA_TL_DOC_MODULES="kpathsea.doc"
+
+for i in ${EXTRA_TL_MODULES} ; do
+ SRC_URI="${SRC_URI} https://dev.gentoo.org/~zlogene/distfiles/texlive/tl-${i}-${TL_VERSION}.tar.xz"
+done
+
+SRC_URI="${SRC_URI} doc? ( "
+for i in ${EXTRA_TL_DOC_MODULES} ; do
+ SRC_URI="${SRC_URI} https://dev.gentoo.org/~zlogene/distfiles/texlive/tl-${i}-${TL_VERSION}.tar.xz"
+done
+SRC_URI="${SRC_URI} ) "
+
+TEXMF_PATH=/usr/share/texmf-dist
+
+src_prepare() {
+ default
+ cd "${WORKDIR}/texlive-${PV#*_p}-source" || die
+ S="${WORKDIR}/texlive-${PV#*_p}-source" elibtoolize
+ cp "${FILESDIR}/texmf-update-r2" "${S}"/texmf-update || die
+ eprefixify "${S}"/texmf-update
+}
+
+src_configure() {
+ # Too many regexps use A-Z a-z constructs, what causes problems with locales
+ # that don't have the same alphabetical order than ascii. Bug #347798
+ # So we set LC_ALL to C in order to avoid problems.
+ export LC_ALL=C
+
+ # Disable largefile because it seems to cause problems on big endian 32 bits
+ # systems...
+ econf \
+ --disable-largefile \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" web2cdir="${EPREFIX}/usr/share/texmf-dist/web2c" install
+ find "${D}" -name '*.la' -delete || die
+
+ dodir /usr/share # just in case
+ cp -pR "${WORKDIR}"/texmf-dist "${ED}/usr/share/" || die "failed to install texmf trees"
+ if use source ; then
+ cp -pR "${WORKDIR}"/tlpkg "${ED}/usr/share/" || die "failed to install tlpkg files"
+ fi
+
+ # Take care of fmtutil.cnf and texmf.cnf
+ dodir /etc/texmf/{fmtutil.d,texmf.d}
+
+ # Remove default texmf.cnf to ship our own, greatly based on texlive dvd's
+ # texmf.cnf
+ # It will also be generated from /etc/texmf/texmf.d files by texmf-update
+ rm -f "${ED}${TEXMF_PATH}/web2c/texmf.cnf" || die
+
+ insinto /etc/texmf/texmf.d
+ doins "${WORKDIR}/texmf.d/"*.cnf
+
+ # Remove fmtutil.cnf, it will be regenerated from /etc/texmf/fmtutil.d files
+ # by texmf-update
+ rm -f "${ED}${TEXMF_PATH}/web2c/fmtutil.cnf" || die
+
+ dosym ../../../../etc/texmf/web2c/fmtutil.cnf ${TEXMF_PATH}/web2c/fmtutil.cnf
+ dosym ../../../../etc/texmf/web2c/texmf.cnf ${TEXMF_PATH}/web2c/texmf.cnf
+
+ newsbin "${S}/texmf-update" texmf-update
+
+ # Keep it as that's where the formats will go
+ keepdir /var/lib/texmf
+
+ dodoc ChangeLog NEWS PROJECTS README
+
+ # The default configuration expects it to be world writable, bug #266680
+ # People can still change it with texconfig though.
+ dotmpfiles "${FILESDIR}"/kpathsea.conf
+}
+
+pkg_postinst() {
+ tmpfiles_process "${FILESDIR}"/kpathsea.conf
+ etexmf-update
+}
+
+pkg_postrm() {
+ etexmf-update
+}