summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-12-28 13:42:58 +0100
committerDavid Seifert <soap@gentoo.org>2020-12-28 13:42:58 +0100
commitc62a99885c8e4211be26e51641f99e81f3986b54 (patch)
tree73f4cd6bbdc681ff68b2138e896908df8608f5be
parentsys-fabric/libcxgb3: Port to EAPI 6 (diff)
downloadgentoo-c62a99885c8e4211be26e51641f99e81f3986b54.tar.gz
gentoo-c62a99885c8e4211be26e51641f99e81f3986b54.tar.bz2
gentoo-c62a99885c8e4211be26e51641f99e81f3986b54.zip
www-client/uget: Port to EAPI 7
Closes: https://bugs.gentoo.org/713812 Package-Manager: Portage-3.0.9, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--www-client/uget/files/uget-2.2.1-fno-common.patch8
-rw-r--r--www-client/uget/uget-2.2.1.ebuild29
2 files changed, 18 insertions, 19 deletions
diff --git a/www-client/uget/files/uget-2.2.1-fno-common.patch b/www-client/uget/files/uget-2.2.1-fno-common.patch
new file mode 100644
index 000000000000..8910c338e80f
--- /dev/null
+++ b/www-client/uget/files/uget-2.2.1-fno-common.patch
@@ -0,0 +1,8 @@
+--- a/ui-gtk/UgtkBanner.h
++++ b/ui-gtk/UgtkBanner.h
+@@ -64,7 +64,7 @@
+ UgetRssFeed* feed;
+ UgetRssItem* item;
+ } rss;
+-} banner;
++};
diff --git a/www-client/uget/uget-2.2.1.ebuild b/www-client/uget/uget-2.2.1.ebuild
index 3608bf8baca1..de91193f2cd9 100644
--- a/www-client/uget/uget-2.2.1.ebuild
+++ b/www-client/uget/uget-2.2.1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=7
-inherit gnome2-utils xdg-utils
+inherit xdg
DESCRIPTION="Download manager using gtk+ and libcurl"
HOMEPAGE="http://www.ugetdm.com"
@@ -16,9 +16,9 @@ IUSE="aria2 appindicator control-socket +gnutls gstreamer libnotify nls openssl
REQUIRED_USE="^^ ( gnutls openssl )"
RDEPEND="
- >=net-misc/curl-7.19.1
+ dev-libs/glib:2
dev-libs/libpcre
- >=dev-libs/glib-2.32:2
+ net-misc/curl
>=x11-libs/gtk+-3.4:3
gnutls? (
net-libs/gnutls
@@ -28,13 +28,14 @@ RDEPEND="
appindicator? ( dev-libs/libappindicator:3 )
gstreamer? ( media-libs/gstreamer:1.0 )
libnotify? ( x11-libs/libnotify )
- openssl? ( dev-libs/openssl:0 )
- "
-DEPEND="${RDEPEND}
+ openssl? ( dev-libs/openssl:0 )"
+DEPEND="${RDEPEND}"
+BDEPEND="
dev-util/intltool
- virtual/pkgconfig
sys-devel/gettext
- "
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )
src_configure() {
local myconf=(
@@ -50,13 +51,3 @@ src_configure() {
econf "${myconf[@]}"
}
-
-pkg_postinst() {
- xdg_desktop_database_update
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_desktop_database_update
- gnome2_icon_cache_update
-}