summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-16 05:37:06 +0100
committerSam James <sam@gentoo.org>2023-04-16 05:37:06 +0100
commitc62e9843f14a614b30298ae12f30063786fc0d50 (patch)
treedcf746f7c38fe7adf2291f87f4095fe31f7f43d6
parentx11-terms/kitty: update live (diff)
downloadgentoo-c62e9843f14a614b30298ae12f30063786fc0d50.tar.gz
gentoo-c62e9843f14a614b30298ae12f30063786fc0d50.tar.bz2
gentoo-c62e9843f14a614b30298ae12f30063786fc0d50.zip
sys-apps/groff: add 1.23.0_rc4
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-apps/groff/Manifest1
-rw-r--r--sys-apps/groff/groff-1.23.0_rc4.ebuild108
2 files changed, 109 insertions, 0 deletions
diff --git a/sys-apps/groff/Manifest b/sys-apps/groff/Manifest
index 6b3da3030a5b..e88718da26dd 100644
--- a/sys-apps/groff/Manifest
+++ b/sys-apps/groff/Manifest
@@ -1,2 +1,3 @@
DIST groff-1.22.4.tar.gz 4137480 BLAKE2B cdda8a7e8e42b8d8991656ecfbffe0cd0ed5d8932467cab2f3c1eecb3365f4a5c03321b6ed929d451c3dfb00a46046a781303a1c55c4aa65eb7d178fb36b1cbc SHA512 1c42d3cd71efaf067b5850945d9097fa1f0fadd5e2b6ba7446bd9d4f439fe1ad058e4ddb0d4e0f503682137dfc7c822944ce1e3e5cf981673f8ba197ea77126d
DIST groff-1.23.0.rc3.tar.gz 7347387 BLAKE2B d61ccf18450816abb2436799c3ffac0ce0bc827ad4f262c94e172b0dbaae18593b7562576067e0380ff96cbc40b4fe63382082867659fbc6971cadc81e8dc36d SHA512 bfdc6761e02b698b7d7dac059c14c1f3de94057cda4952aca2fa41da3bd9657daef86bdddc46a392397ccb761f627d1652ce5f4a38890c480fbdb89f9926b662
+DIST groff-1.23.0.rc4.tar.gz 7363288 BLAKE2B 3873cecf16f0ec474a1272396da95fd59437d3886b46e4dce8975f608251a8b23035a059650c0f05f7debbf13922a862be4c5168c25536111448e6c54b7ae987 SHA512 a65cae5d383fdbd7ac72f9bf6087cc290f2f8133b7040c5749d4dfee4427369643065ba4c6eedda1402cd3b9861440fcd6cb954cf3061beae140b18426162428
diff --git a/sys-apps/groff/groff-1.23.0_rc4.ebuild b/sys-apps/groff/groff-1.23.0_rc4.ebuild
new file mode 100644
index 000000000000..795366532403
--- /dev/null
+++ b/sys-apps/groff/groff-1.23.0_rc4.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_P="${P/_/.}"
+DESCRIPTION="Text formatter used for man pages"
+HOMEPAGE="https://www.gnu.org/software/groff/groff.html"
+
+if [[ ${PV} == *_rc* ]] ; then
+ SRC_URI="https://alpha.gnu.org/gnu/groff/${MY_P}.tar.gz"
+else
+ SRC_URI="mirror://gnu/groff/${MY_P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="examples uchardet X"
+
+RDEPEND="
+ uchardet? ( app-i18n/uchardet )
+ X? (
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXmu
+ x11-libs/libXt
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-lang/perl
+ sys-apps/texinfo
+"
+
+DOCS=( BUG-REPORT ChangeLog MORE.STUFF NEWS PROBLEMS PROJECTS README TODO )
+
+PATCHES=(
+ # bug #16108, bug #17580, bug #121502
+ "${FILESDIR}"/${PN}-1.19.2-man-unicode-dashes.patch
+)
+
+src_prepare() {
+ default
+
+ # Honor Gentoo's docdir
+ sed -i -e "s|^docdir =.*|docdir = \"${EPREFIX}/usr/share/doc/${PF}\"|g" \
+ Makefile.in \
+ || die "failed to modify Makefile.in"
+
+ local pfx=$(usex prefix ' Prefix' '')
+ cat <<-EOF >> tmac/mdoc.local || die
+ .ds volume-operating-system Gentoo${pfx}
+ .ds operating-system Gentoo${pfx}/${KERNEL}
+ .ds default-operating-system Gentoo${pfx}/${KERNEL}
+ EOF
+
+ # make sure we don't get a crappy `g' nameprefix on UNIX systems with real
+ # troff (GROFF_G macro runs some test to see, its own troff doesn't satisfy)
+ sed -i -e 's/^[ \t]\+g=g$/g=/' configure || die
+}
+
+src_configure() {
+ local myeconfargs=(
+ --with-appdefdir="${EPREFIX}"/usr/share/X11/app-defaults
+ $(use_with uchardet)
+ $(use_with X x)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ local -a CROSS_ARGS
+ tc-is-cross-compiler && CROSS_ARGS+=(
+ GROFFBIN="$(type -P groff)"
+ TROFFBIN="$(type -P troff)"
+ GROFF_BIN_DIR=
+ GROFF_BIN_PATH=
+ )
+
+ emake AR="$(tc-getAR)" "${CROSS_ARGS[@]}"
+}
+
+src_install() {
+ default
+
+ # The following links are required for man, bug #123674
+ dosym eqn /usr/bin/geqn
+ dosym tbl /usr/bin/gtbl
+
+ if ! use examples ; then
+ # The pdf files might not be generated if ghostscript is unavailable, bug #602020
+ local pdf="${ED}/usr/share/doc/${PF}/examples/mom/mom-pdf.pdf"
+ if [[ -e ${pdf} ]] ; then
+ # Keep mom-pdf.pdf since it's more of a manual than an example
+ # bug #454196 and bug #516732
+ mv "${pdf}" "${ED}/usr/share/doc/${PF}/pdf/" || die
+ fi
+ rm -rf "${ED}/usr/share/doc/${PF}/examples"
+ fi
+}