summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-03-30 03:34:07 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-03-30 03:34:07 +0200
commitc6324820ccbaf353741610ae3580911cb06a00dd (patch)
treec1785e21a18c9daeb04ccc98599897f612e67a5b
parentdev-util/checkbashisms: bump to v2.20.2 (diff)
downloadgentoo-c6324820.tar.gz
gentoo-c6324820.tar.bz2
gentoo-c6324820.zip
sys-apps/logwatch: bump to v7.5.3
Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--sys-apps/logwatch/Manifest1
-rw-r--r--sys-apps/logwatch/logwatch-7.5.3.ebuild95
2 files changed, 96 insertions, 0 deletions
diff --git a/sys-apps/logwatch/Manifest b/sys-apps/logwatch/Manifest
index c578f32578d5..032d1f21a708 100644
--- a/sys-apps/logwatch/Manifest
+++ b/sys-apps/logwatch/Manifest
@@ -1,2 +1,3 @@
DIST logwatch-7.5.1.tar.gz 469715 BLAKE2B 706352c60370d13b4f72047d08965ab0dd36837194a03bf44e08ec43641eddb8d80d655c783d4f25c8fa757853a4e069997b80676b781561c5e0a23b44a393c9 SHA512 945e66192a9e198169426497f7b5167fcbec2af9565dfead728aa91bfdac5f7e1b2ce2f5f404b6f03841fe6b978f70fb969b47d4f60f02f9a8ccea865c5c782c
DIST logwatch-7.5.2.tar.gz 475277 BLAKE2B e3d841749af4776da84646444dd90bb084dc33712c1a6eeab87d46cb267656527008505f78506168b7ded40f3d0f8209c205249c2f953e6ee8af7a6cd82833d9 SHA512 157486143ba12167f6c50c778372a4295db3744878607bceba8e0813357651bffd8924ef5ef41a4fbd20811c020dcc031eb354a0f52b8eb6d9aac197087c2bc5
+DIST logwatch-7.5.3.tar.gz 495110 BLAKE2B b28d7381d259a132de7d9fd347ac4bafb44440b187aa811f3d3f65d7b1ccbb00c6b5bb660229cd8155fa5d7bc9668e7b4dd1ebe7bbb909b48367c6a6dd6793e5 SHA512 ad404f031fe016599a8f8d8c0820b23db61a9ad102815d3713e5d13e9a810c819ca7ad9cea50891852982e073ef033dbe7595fde8846971336148e32cbbe29ca
diff --git a/sys-apps/logwatch/logwatch-7.5.3.ebuild b/sys-apps/logwatch/logwatch-7.5.3.ebuild
new file mode 100644
index 000000000000..6b03d4907f51
--- /dev/null
+++ b/sys-apps/logwatch/logwatch-7.5.3.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit tmpfiles
+
+PATCHES=()
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://git.code.sf.net/p/logwatch/git ${PN}"
+ inherit git-r3
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+DESCRIPTION="Analyzes and Reports on system logs"
+HOMEPAGE="http://www.logwatch.org/"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="virtual/cron
+ virtual/mta
+ virtual/mailx
+ dev-lang/perl
+ dev-perl/Date-Calc
+ dev-perl/Date-Manip
+ dev-perl/Tie-IxHash
+ dev-perl/Sys-CPU
+ dev-perl/Sys-MemInfo"
+
+src_install() {
+ dodir /usr/share/logwatch/lib
+ dodir /usr/share/logwatch/scripts/services
+ dodir /usr/share/logwatch/scripts/shared
+ dodir /usr/share/logwatch/default.conf/logfiles
+ dodir /usr/share/logwatch/default.conf/services
+ dodir /usr/share/logwatch/default.conf/html
+ keepdir /etc/logwatch
+
+ # logwatch.pl requires cache dir (bug #607668)
+ newtmpfiles "${FILESDIR}"/logwatch.tmpfile ${PN}.conf
+
+ newsbin scripts/logwatch.pl logwatch.pl
+
+ exeinto /usr/share/logwatch/lib
+ doexe lib/*.pm
+
+ exeinto /usr/share/logwatch/scripts/services
+ doexe scripts/services/*
+
+ exeinto /usr/share/logwatch/scripts/shared
+ doexe scripts/shared/*
+
+ insinto /usr/share/logwatch/default.conf
+ doins conf/logwatch.conf
+
+ insinto /usr/share/logwatch/default.conf/logfiles
+ doins conf/logfiles/*
+
+ insinto /usr/share/logwatch/default.conf/services
+ doins conf/services/*
+
+ insinto /usr/share/logwatch/default.conf/html
+ doins conf/html/*
+
+ # Make sure logwatch is run before anything else #100243
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/logwatch 00-logwatch
+
+ doman logwatch.8
+ dodoc README HOWTO-Customize-LogWatch
+
+ # Do last due to insopts modification.
+ insinto /usr/share/logwatch/scripts/logfiles
+ insopts -m755
+ doins -r scripts/logfiles/*
+}
+
+pkg_postinst() {
+ # Migration from /etc/cron.daily/logwatch -> /etc/cron.daily/00-logwatch (bug #100243)
+ if [[ -e ${ROOT}/etc/cron.daily/logwatch ]] ; then
+ local md5=$(md5sum "${ROOT}"/etc/cron.daily/logwatch)
+ [[ ${md5} == "edb003cbc0686ed4cf37db16025635f3" ]] \
+ && rm -f "${ROOT}"/etc/cron.daily/logwatch \
+ || ewarn "You have two logwatch files in /etc/cron.daily/"
+ fi
+
+ # Trigger cache dir creation to allow immediate use of logwatch (bug #607668)
+ tmpfiles_process ${PN}.conf
+}