summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-08-02 12:11:22 -0400
committerTim Harder <radhermit@gentoo.org>2016-08-02 12:20:18 -0400
commitc632867a039d61a5525305aff58a90a054d88267 (patch)
treedb8fe2e1b914a0571be65bfda3eeb4636de2b3a2
parentxfce-extra/xfdashboard: Prune old (diff)
downloadgentoo-c632867a.tar.gz
gentoo-c632867a.tar.bz2
gentoo-c632867a.zip
net-mail/offlineimap: only show postinst message for new installs
Also, fix dev-python/six dep to use proper python versions.
-rw-r--r--net-mail/offlineimap/offlineimap-7.0.3-r1.ebuild22
1 files changed, 12 insertions, 10 deletions
diff --git a/net-mail/offlineimap/offlineimap-7.0.3-r1.ebuild b/net-mail/offlineimap/offlineimap-7.0.3-r1.ebuild
index 6de39f8cf15a..ed8d23442052 100644
--- a/net-mail/offlineimap/offlineimap-7.0.3-r1.ebuild
+++ b/net-mail/offlineimap/offlineimap-7.0.3-r1.ebuild
@@ -6,7 +6,7 @@ EAPI=6
# Normally you need only one version of this.
DISTUTILS_SINGLE_IMPL=1
-PYTHON_COMPAT=( python2_7 python3_4 )
+PYTHON_COMPAT=( python{2_7,3_4} )
PYTHON_REQ_USE="threads,sqlite,ssl?"
inherit distutils-r1
@@ -20,7 +20,7 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE="doc ssl"
-RDEPEND="dev-python/six"
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
DEPEND="doc? ( app-text/asciidoc )"
# see http://pogma.com/2009/09/09/snow-leopard-and-offlineimap/ and bug 284925
@@ -41,12 +41,14 @@ src_install() {
}
pkg_postinst() {
- elog "You will need to configure offlineimap by creating ~/.offlineimaprc"
- elog "Sample configurations are in /usr/share/doc/${PF}/"
- elog ""
- elog "If you connect via ssl/tls and don't use CA cert checking, it will"
- elog "display the server's cert fingerprint and require you to add it to the"
- elog "configuration file to be sure it connects to the same server every"
- elog "time. This serves to help fixing CVE-2010-4532 (offlineimap doesn't"
- elog "check SSL server certificate) in cases where you have no CA cert."
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "You will need to configure offlineimap by creating ~/.offlineimaprc"
+ elog "Sample configurations are in /usr/share/doc/${PF}/"
+ elog ""
+ elog "If you connect via ssl/tls and don't use CA cert checking, it will"
+ elog "display the server's cert fingerprint and require you to add it to the"
+ elog "configuration file to be sure it connects to the same server every"
+ elog "time. This serves to help fixing CVE-2010-4532 (offlineimap doesn't"
+ elog "check SSL server certificate) in cases where you have no CA cert."
+ fi
}