summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2018-02-07 23:11:15 +0100
committerUlrich Müller <ulm@gentoo.org>2018-02-07 23:25:38 +0100
commitc646da6efad8ea922cf6f47487c2907fd41cdaa5 (patch)
tree888ae58dc1ef2d50f18809eb3b7003ee763e48eb
parentapp-shells/rrs: clean up old. (diff)
downloadgentoo-c646da6e.tar.gz
gentoo-c646da6e.tar.bz2
gentoo-c646da6e.zip
app-editors/zile: Retrieve list of ncurses libs from pkg-config.
Fixes build failure with sys-apps/ncurses[tinfo]. Closes: https://bugs.gentoo.org/646916 Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--app-editors/zile/zile-2.3.24-r2.ebuild6
-rw-r--r--app-editors/zile/zile-2.4.13.ebuild6
-rw-r--r--app-editors/zile/zile-2.4.14.ebuild6
3 files changed, 15 insertions, 3 deletions
diff --git a/app-editors/zile/zile-2.3.24-r2.ebuild b/app-editors/zile/zile-2.3.24-r2.ebuild
index ff2a5d21a82e..bc74d29787ac 100644
--- a/app-editors/zile/zile-2.3.24-r2.ebuild
+++ b/app-editors/zile/zile-2.3.24-r2.ebuild
@@ -3,6 +3,8 @@
EAPI=6
+inherit toolchain-funcs
+
DESCRIPTION="Zile is a small Emacs clone"
HOMEPAGE="https://www.gnu.org/software/zile/"
SRC_URI="mirror://gnu/zile/${P}.tar.gz"
@@ -14,6 +16,7 @@ IUSE="test valgrind"
RDEPEND="sys-libs/ncurses:0="
DEPEND="${RDEPEND}
+ virtual/pkgconfig
test? ( valgrind? ( dev-util/valgrind ) )"
PATCHES=("${FILESDIR}"/${P}-{userhome,gets}.patch)
@@ -22,7 +25,8 @@ src_configure() {
# --without-emacs to suppress tests for GNU Emacs #630652
econf \
--without-emacs \
- $(use test && use_with valgrind || echo "--without-valgrind")
+ $(use test && use_with valgrind || echo "--without-valgrind") \
+ CURSES_LIB="$("$(tc-getPKG_CONFIG)" --libs ncurses)"
}
src_install() {
diff --git a/app-editors/zile/zile-2.4.13.ebuild b/app-editors/zile/zile-2.4.13.ebuild
index d7578b2406fd..d6136b4f5a1e 100644
--- a/app-editors/zile/zile-2.4.13.ebuild
+++ b/app-editors/zile/zile-2.4.13.ebuild
@@ -3,6 +3,8 @@
EAPI=6
+inherit toolchain-funcs
+
DESCRIPTION="Zile is a small Emacs clone"
HOMEPAGE="https://www.gnu.org/software/zile/"
SRC_URI="mirror://gnu/zile/${P}.tar.gz"
@@ -17,6 +19,7 @@ RDEPEND=">=dev-libs/boehm-gc-7.2:=
acl? ( virtual/acl )"
DEPEND="${RDEPEND}
+ virtual/pkgconfig
test? ( dev-lang/perl )"
QA_AM_MAINTAINER_MODE=".*help2man.*" #450278
@@ -26,7 +29,8 @@ src_configure() {
econf \
--docdir="${EPREFIX}"/usr/share/doc/${PF} \
--without-emacs \
- $(use_enable acl)
+ $(use_enable acl) \
+ CURSES_LIB="$("$(tc-getPKG_CONFIG)" --libs ncurses)"
}
src_install() {
diff --git a/app-editors/zile/zile-2.4.14.ebuild b/app-editors/zile/zile-2.4.14.ebuild
index 3754cfad686a..3438a470a0a9 100644
--- a/app-editors/zile/zile-2.4.14.ebuild
+++ b/app-editors/zile/zile-2.4.14.ebuild
@@ -3,6 +3,8 @@
EAPI=6
+inherit toolchain-funcs
+
DESCRIPTION="Zile is a small Emacs clone"
HOMEPAGE="https://www.gnu.org/software/zile/"
SRC_URI="mirror://gnu/zile/${P}.tar.gz"
@@ -17,6 +19,7 @@ RDEPEND=">=dev-libs/boehm-gc-7.2:=
acl? ( virtual/acl )"
DEPEND="${RDEPEND}
+ virtual/pkgconfig
test? ( dev-lang/perl )"
QA_AM_MAINTAINER_MODE=".*help2man.*" #450278
@@ -27,7 +30,8 @@ src_configure() {
--docdir="${EPREFIX}"/usr/share/doc/${PF} \
--without-emacs \
--disable-valgrind-tests \
- $(use_enable acl)
+ $(use_enable acl) \
+ CURSES_LIB="$("$(tc-getPKG_CONFIG)" --libs ncurses)"
}
src_install() {