summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-20 19:53:34 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-20 19:57:02 +0200
commitc65df201e940aef7c43acc9e4bf0cccd9a3eb3a5 (patch)
treee1afb17afd5a7164a6381e9cf2e3762180d19357
parentdev-python/pyyaml: Remove old (diff)
downloadgentoo-c65df201e940aef7c43acc9e4bf0cccd9a3eb3a5.tar.gz
gentoo-c65df201e940aef7c43acc9e4bf0cccd9a3eb3a5.tar.bz2
gentoo-c65df201e940aef7c43acc9e4bf0cccd9a3eb3a5.zip
dev-python/meson-python: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/meson-python/Manifest1
-rw-r--r--dev-python/meson-python/meson-python-0.13.1.ebuild66
2 files changed, 0 insertions, 67 deletions
diff --git a/dev-python/meson-python/Manifest b/dev-python/meson-python/Manifest
index 589e9f7fd4b2..120dbde79529 100644
--- a/dev-python/meson-python/Manifest
+++ b/dev-python/meson-python/Manifest
@@ -1,2 +1 @@
-DIST meson-python-0.13.1.gh.tar.gz 69434 BLAKE2B c3442eb1c066772b80efe4e41764897df85a3581c94f9d958951af04e9ad7a01c646c7ed7f0104fbe957567e16b80c6e3744ab23b6b66a8df3cc920cb68c852f SHA512 037825eabcaec5bdb73890114ecfcfb05373bcb5e2806a8d38e4afeeecea42aa14f9c8cf0bec151bd231e2984c64608b28a1ec79640485933cd57c8895b6a305
DIST meson-python-0.13.2.gh.tar.gz 69575 BLAKE2B ddcab5530e7c235057752f1c355052120863167fc601b669e3add713079400cf95617be84989e06542125850559124d70a693a618cbec456c0e59e3f80d14c5f SHA512 b5518c5e9ccbec40747f2c08a83134f012557e0d9612b99999473d2ae7fdfdeae5b7552dc16cebb493133c3ed8c52153b3e3afd3cef32d0f3a65771ebbb5b3bb
diff --git a/dev-python/meson-python/meson-python-0.13.1.ebuild b/dev-python/meson-python/meson-python-0.13.1.ebuild
deleted file mode 100644
index ca91f1cba7bc..000000000000
--- a/dev-python/meson-python/meson-python-0.13.1.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=standalone
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Meson PEP 517 Python build backend"
-HOMEPAGE="
- https://pypi.org/project/meson-python/
- https://github.com/mesonbuild/meson-python/
-"
-SRC_URI="
- https://github.com/mesonbuild/meson-python/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 ~sparc x86"
-
-RDEPEND="
- >=dev-python/pyproject-metadata-0.7.1[${PYTHON_USEDEP}]
- >=dev-util/meson-0.63.0[${PYTHON_USEDEP}]
- dev-util/patchelf
- $(python_gen_cond_dep '
- >=dev-python/tomli-1.0.0[${PYTHON_USEDEP}]
- ' 3.10)
-"
-BDEPEND="
- >=dev-python/cython-0.29.34[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # requires network access
- tests/test_pep518.py::test_pep518
- # requires git repo
- # https://github.com/mesonbuild/meson-python/issues/397
- tests/test_project.py::test_user_args
- )
- unset NINJA
-
- if [[ ${EPYTHON} == pypy3 ]]; then
- EPYTEST_DESELECT+=(
- # broken venv usage that copies pypy3 executable, making it
- # unable to find lib_pypy
- tests/test_editable.py::test_editable_install
- tests/test_editable.py::test_editble_reentrant
- tests/test_examples.py::test_spam
- tests/test_wheel.py::test_local_lib
- )
- fi
-
- epytest
-
- rm -rf docs/examples/spam/build/ || die # remove artifacts
-}