summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2023-02-01 10:43:16 -0800
committerPatrick McLean <chutzpah@gentoo.org>2023-02-01 10:44:08 -0800
commitc66083abfa820c0208f15a068c55dca4a23a54b6 (patch)
tree67fa7405ba8801a3bc2fcbd21419cf134f19943b
parentdev-lang/go: Stabilize 1.19.5 arm64, #891317 (diff)
downloadgentoo-c66083abfa820c0208f15a068c55dca4a23a54b6.tar.gz
gentoo-c66083abfa820c0208f15a068c55dca4a23a54b6.tar.bz2
gentoo-c66083abfa820c0208f15a068c55dca4a23a54b6.zip
app-misc/check-jsonschema: new package, add 0.21.0
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--app-misc/check-jsonschema/Manifest1
-rw-r--r--app-misc/check-jsonschema/check-jsonschema-0.21.0.ebuild50
-rw-r--r--app-misc/check-jsonschema/metadata.xml12
3 files changed, 63 insertions, 0 deletions
diff --git a/app-misc/check-jsonschema/Manifest b/app-misc/check-jsonschema/Manifest
new file mode 100644
index 000000000000..9e241f8226ce
--- /dev/null
+++ b/app-misc/check-jsonschema/Manifest
@@ -0,0 +1 @@
+DIST check-jsonschema-0.21.0.gh.tar.gz 214872 BLAKE2B 0ee013e379523e5a957e745d550c2014872eab9fc3281aad575f92abfada30b7e0853177bd06147b69a81100bf6b987b485342a087830845c32648efc1c7a9a0 SHA512 dd839a9bb104e1fc68e4a7507077dc991dfc9e840f785c4b7024f2838488eb8b8c6a8f7718f0f821981f5b6b23b1d67745948f48db55a0c589395cf43bfdd2a7
diff --git a/app-misc/check-jsonschema/check-jsonschema-0.21.0.ebuild b/app-misc/check-jsonschema/check-jsonschema-0.21.0.ebuild
new file mode 100644
index 000000000000..26d7ad3e1777
--- /dev/null
+++ b/app-misc/check-jsonschema/check-jsonschema-0.21.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="A CLI and set of pre-commit hooks for jsonschema validation"
+HOMEPAGE="
+ https://pypi.org/project/check-jsonschema/
+ https://github.com/python-jsonschema/check-jsonschema
+"
+SRC_URI="https://github.com/python-jsonschema/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=(
+ README.md
+ CONTRIBUTING.md
+ CHANGELOG.rst
+)
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/furo
+
+python_prepare_all() {
+ # relax deps in setup.cfg
+ sed -r -e 's:([a-zA-Z.-]+)([<>]|==|[<>]=)+.+:\1: ; /importlib-resources/ d' -i setup.cfg || die
+
+ distutils-r1_python_prepare_all
+}
diff --git a/app-misc/check-jsonschema/metadata.xml b/app-misc/check-jsonschema/metadata.xml
new file mode 100644
index 000000000000..0b93e3e929e1
--- /dev/null
+++ b/app-misc/check-jsonschema/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">python-jsonschema/check-jsonschema</remote-id>
+ <remote-id type="pypi">check-jsonschema</remote-id>
+ </upstream>
+</pkgmetadata>